jara257
Hi Thiago,

I have been trying to run the a program on the simulator and gives me this error:

Start build in F:\RPi\build
Generating SoftPLC IEC-61131 ST/IL/SFC code...
Compiling IEC Program into C code...
Extracting Located Variables...
C code generated successfully.
PLC :
[CC] plc_main.c -> plc_main.o
[CC] plc_debugger.c -> plc_debugger.o
py_ext :
[CC] py_ext.c -> py_ext.o
PLC :
[CC] Config0.c -> Config0.o
[CC] Res0.c -> Res0.o
Linking :
[CC] plc_main.o plc_debugger.o py_ext.o Config0.o Res0.o -> RPi.dll
Successfully built.
Beremiz_service: 1.0
Traceback (most recent call last):
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\editor\Beremiz_service.py", line 402, in <module>
"C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\pythonw.exe" "C:\Users\Johnatan\Desktop\OpenPLC Editor\editor\Beremiz_service.py" -p 61670 -i localhost -x 1 c:\users\johnatan\appdata\local\temp\tmp1fy0bm
wxreactor.install()
exited with status 1 (pid 2156)
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\site-packages\twisted\internet\wxreactor.py", line 178, in install
reactor = WxReactor()
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\site-packages\twisted\internet\_threadedselect.py", line 105, in __init__
posixbase.PosixReactorBase.__init__(self)
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\site-packages\twisted\internet\base.py", line 489, in __init__
self.installWaker()
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\site-packages\twisted\internet\posixbase.py", line 266, in installWaker
self.waker = _Waker(self)
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\site-packages\twisted\internet\posixbase.py", line 74, in __init__
client.connect(server.getsockname())
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\lib\socket.py", line 228, in meth
return getattr(self._sock,name)(*args)
socket.error: [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
PYRO connecting to URI : PYROLOC://127.0.0.1:61670
Exception while connecting to 'LOCAL://': connection failed
Connection failed to LOCAL://!

Thanks for your help
Quote 0 0
thiagoralves
Looks like Beremiz Service is failing to launch on your computer for some reason:
File "C:\Users\Johnatan\Desktop\OpenPLC Editor\editor\Beremiz_service.py", line 402, in <module>
"C:\Users\Johnatan\Desktop\OpenPLC Editor\Python\pythonw.exe" "C:\Users\Johnatan\Desktop\OpenPLC Editor\editor\Beremiz_service.py" -p 61670 -i localhost -x 1 c:\users\johnatan\appdata\local\temp\tmp1fy0bm
wxreactor.install()
exited with status 1 (pid 2156)

Do you have any firewall or antivirus active? They could be blocking Beremiz Service since it opens a port to communicate with the editor
Quote 0 0
jara257
Hi Thanks for the reply,

I had both firewall and antivirus disable. I run the program again but not luck I had even delete and re-install the editor but still same error. 

Is there anything else I can do to fix that?
Quote 0 0
thiagoralves
Really hard to tell without seeing your machine. If you're familiar with Linux and Virtual Machines, maybe the easiest approach is just to spin up a Ubuntu Virtual Machine (using VMWare or Virtualbox), and install the editor in there.
Quote 0 0
jara257
Thanks for your help, It seems that I had installed the editor somehow wrong, Now its working ok.
Quote 0 0