BenKissBox
Hello to all,

First, I hope that all OpenPLC members are passing through this world's crisis without problems and all of your families are safe.

I have encountered a strange problem while installing OpenPLC Editor on my Debian 10 machine. When I launch ./install.sh, it reports a python syntax error  😯

File "/tmp/easy_install-xxxxxxxxxx /setup.py" line 182
  raise ValueError (f'Submodule {p} missing')
                                                                   ^
SyntaxError : invalid syntax


The error marker points to the quote after "missing" word. I can't see what is wrong here

Fun thing : the OpenPLC Editor logo appears in my "Other" applications folder, but it does not start (probably because of the python issue)

Anybody has an idea of what explains this ?

Thanks

Benoit
Quote 0 0
thiagoralves
It probably failed while trying to install some of the dependencies. Hard to point which dependency it was without the full log. The error seems to be related to easy_install, a common python script to install libraries.
Quote 0 0
BenKissBox
Hi Thiago,

that's what I tought too at the beginning, but looking at the logs, the only thing I could see as a problem was the line reported in the post.

I wanted to run ./ install.sh again to make a complete copy of the log (rather than checking in the console) and try to guess what happened : this time it worked like a charm 😜

I will repeat my experiment, because I did something on my machine meanwhile : as I wanted to try to install Beremiz from their main repository, I have installed the prerequisites, so maybe one of the libraries I installed manually solved the problem in python.

Here are the packages I installed meanwhile

sudo apt-get install python-wxgtk3.0 pyro mercurial
sudo apt-get install build-essential bison flex python-numpy python-nevow


But at least, OpenPLC Editor runs now on my Debian 10 machine here 😉
I will try to generate a quick and dirty program to check if matiec also works

Benoit
Quote 0 0
thiagoralves
These are the same dependencies required by OpenPLC Editor as well:
echo "[INSTALLING DEPENDENCIES]"
sudo apt-get -y -qq update
sudo apt-get -y -qq install curl build-essential pkg-config bison flex autoconf automake libtool make git libssl-dev python2 python-wxgtk3.0
curl https://bootstrap.pypa.io/get-pip.py --output get-pip.py
sudo python2 get-pip.py
sudo apt-get -y -qq install python2-dev
#Fix for Debian Buster
sudo apt-get -y -qq install libpng libfreetype6-dev
pip2 install future zeroconf==0.19.1 numpy==1.16.5 matplotlib==2.0.2 lxml pyro sslpsk

The difference is that OpenPLC Editor installer tries to install them through pip2 instead of apt-get sources. The advantage of pip is that you can specify which version you want. After a lot of trial and error, I've determined that those versions are the ones that works best with the editor
Quote 0 0