Jonathlas
Hi! I had some issues installing OpenPLC v3 on Windows 10 and finally found a way to be able to run it correctly.
I tried the installer on my computer and also a clean windows 10 VM with the same issue.

I'm not a linux person so there may well be an easier way to fix this.

I had errors at theses lines of the installer saying that pip command was not found :
pip install flask
pip install flask-login
pip install pyserial


An easy way to fix is to install cygwin over the Runtime directory (C:/Users/%USERNAME%/OpenPLC/Runtime) with the default values (Check the 'Best' setting, this will update everything to the last version)
Then Rebase OpenPLC in start menu.

Thanks a lot for this, seems very promising, I will continue to try it ! 🙂
Quote 1 0
thiagoralves
Thank you for your input Jonathlas. I don't know why the Windows installer is causing so many errors to some people. I've tried it in many Windows 10 and Windows 7 machines, both 64-bit and 32-bit and never had any issue.
Quote 0 0
alvaroalea
HI, I had the same Issue, installing on a windows 7 machine.
I can confirm that reinstall Cygwin over Runtime will fix the problem, you must force reinstall on each package.

It's seen than during initial instalation some problems with permision cause to really not install the packages (a warning appears that is not posible to make hard-link because of permision) so even if you check with apt-cyg if the package is installed, its really not.
so if you try to execute wget, python, or g++  you get "bash: xxx: can not find the command.
this cause that is not posible to install pip (because python is not found) and after that all the other faults, etc, etc.
Quote 0 0
Rick
Great! This worked for me too.  Had to start over from scratch by uninstalling first, then it all went together.

Thanks!
Quote 0 0