adriano.mele

Hi all,

I am pretty new to this system and I have to say that it seems very nice 🙂

Anyway, I am having a bit of a trouble in setting my system. Here is my situation.

On one side, I have openPLC (runtime+editor) installed on my windows PC. On the other, I installed ScadaBR on a remote Linux server, to which I connect via ssh (using PuTTY).

I tunneled port 9090, so that I can connect to ScadaBR via browser from my windows laptop nicely. But when I try to setup a data source (Modbus IP) it asks for the host and port from which the data are sent.

The default port is 502, so I just tried to forward port 502 to one of the available ports of the Linux server (as I did for the 9090), but I get the following error when I try to connect:

 

14:04:50: 'my_PC': com.serotonin.modbus4j.exception.ModbusInitException: java.net.ConnectException: Connection refused

 

Any idea on what could be the reason? Any hint?


EDIT - I think I solved the issue. Should it be useful to anyone, I just forwarded local port 502 to server's port 8502 using the Remote SSH tunnel option. Apparently, port 502 cannot be forwarded to port 502 (which I guess is reserved?)

Quote 0 0
thiagoralves
All ports below 1024 are reserved on any Linux system. To use them you must have root privileges (or use some other tricks)
Quote 0 0