poojarao_3396
Hi, I am new to Modbus and communications as a whole. I tried emulating this thread with modrimrs2. This is what I have done so far - 
1. Downloaded openplc on windows 10 and created the code as seen in the video. Made changes as mentioned above, i.e change the registers (%QX0.0 --> %QX100.0) etc. 
2. Added the slave device as mentioned. Uploaded the code onto the webserver.  

After I upload the code, it redirects me to the dashboard, I get a "openplc runtime not running" message. And the modrsSIM2 also shows "Connected(0/10)". I thought this was a port issue and allowed an inbound port of 502 in firewall settings. But still no luck. 

Any help is appreciated! 

Thanks a lot in advance,
Pooja.
 
Attached the respective screens below : 

modbus_sim_connections.jpg  runtime_log_error.jpg 
Quote 0 0
thiagoralves
Have you tried clicking on the big rounded red button "Start PLC" on the bottom left? ðŸ˜
Quote 1 0
poojarao_3396
"Obsessed with trees that you miss the woods". I think I missed both. 

But thank you so much!
Quote 0 0