pablofsmelo
Hello,
I am trying to use a Unipi1.1 to trigger a simple coil as per the example ("Hello World), but I am having difficulties. I made the recommended setting for this link (https://www.openplcproject.com/getting-started-unipi) but was unsuccessful. Also, I selected unipi1.1 on web application hardware icon and the build was successful, it seems to me that the i2c module is not initializing properly, because by running the same ladder only on one rpi and compilling as one rpi, the system works. After a series of attempts, I tried to configure the i2c using the following configuration: https://www.dobitaobyte.com.br/i2c-com-raspberry/

I try to run the command i2cdetect -y 1 and no devices are returned. I algo tried using their respective power combinations for hw:
- Only the expansion board;
- Only to RPI;
- RPI and Expansion board.

Can anyone help me ?

Tks.
Quote 0 0
thiagoralves
Your UniPi board might be defective. Try contacting UniPi directly for support. Try using their native programming sofware libraries, and if it also doesn't work, there are great chances your board is really faulty. If it does work, then try using a fresh Raspbian image with OpenPLC to avoid configuration issues.
Quote 0 0