fleaPLC
Hi everybody,
I'd like to install openPLC run-time in my orange pi PC box (Armbian os, an adaptive version of Rasbian Buster ). I've installed using "linux method" https://www.openplcproject.com/getting-started-linux but when try to open the webserver from a remote pc using OrangePiPC_Ipaddr:8080 no way...
may i have to iuse installing as raspberry?

every suggestion is appreciated!
BR
Quote 0 0
thiagoralves
Something wrong might have happened during the installation. It is hard to know without the install logs. Check the install_log.txt file and post here the results
Quote 0 0
fleaPLC
Installation terminated without errors,, anyway I'll made a fresh installing. Do I need to follow ./ install.sh rpi or ./ install.sh linux in Orange Pi PC board?  (in first installation I follow this https://www.openplcproject.com/getting-started-linux)
Quote 0 0
thiagoralves
You should use the linux option. The rpi option has some specific instructions for the Raspberry Pi that probably won't work on the Orange Pi. Can you post your install logs here?
Quote 0 0
fleaPLC
putty_vbeO1SITT1.png 
this is what I get. When I try to get 10.0.0.85:8080  (10.0.0.85 is the IP addres of the Orange PI PC) I get blank page
Quote 0 0
fleaPLC
explorer_hhIodmRFgZ.png 
is it due to this? ./ start_openplc.sh returns error
Quote 0 0
thiagoralves
Yes. Your log shows two errors. The first is related to flask and flask-login (line 248). It says it couldn't install flask login because the system is missing setuptools. The other error is at the end, when the installer is trying to setup the OpenPLC service. Apparently your system might not have the systemctl files in the location the installer is expecting. If the service is not loaded, the only problem is that you will have to start OpenPLC manually every time, but it shouldn't prevent it from running. 
Quote 0 0
fleaPLC
how can I solve it?
Quote 0 0
thiagoralves
Google is your friend.
Quote 0 0
fleaPLC
😁
Quote 0 0
fleaPLC
at the end I've installed on my Raspberry board..no way for Orange pi. On raspberry webserver runs great..I'm testing now. You made a great job!!
Quote 0 0