EinaamAlim
Hi,

I'm a new user of OpenPLC and have followed the steps of the first project on the website. However, I've been getting errors when trying to simulate and/or generate C code from the ladder logic in the Editor (seen below). It seems more like an internal issue than one from a design. The console said the C code generated successfully; upon uploading generated_plc.st to Runtime, it actually runs correctly on Arduino Uno. Still, this error blocks me from simulating ladder logic designs. Error 2 occurs for both simulating and generating C code.
Capture.png
Other information: I initially installed Runtime & Editor and had missing icons in the Editor, so I reinstalled just the editor (hence the path being in OpenPLC Editor v.1.0 - Windows and of a different directory than OpenPLC).

I'd appreciate some insight on why this may be occurring and how to fix it. Thanks, Thiago!
Quote 0 0
thiagoralves
It looks like it couldn’t find mingw in the path. Either the zip was corrupted or the directory you put it in messed it up. I recommend you just download the editor again and extract it in a folder without special characters (like d:\downloads\editor)
Quote 0 0
EinaamAlim
A third reinstall did the trick (sort of). I had to navigate to where the files are located and call the cmd shortcut from there. Using a batch script to change directories and call the executable was what stopped the Editor from properly locating the correct path. In that way, the second install worked but only when doing this and after restarting my machine - odd enough. Thanks!
Quote 0 0