uni
Windows 7 x64 and Windows 10 x64 the same result. PLCOpenEditor 1.2.

2017-04-08 10-25-33 PLCOpenEditor - ~Example~.png 
Quote 0 0
thiagoralves
That's strange, I've never seen this error before. Could it be related to the language of your OS?

Also, usually I create the main program in ladder logic instead of structured text... I just use the other languages for functions and functionBlocks
Quote 0 0
uni
I don't know about the OS language (russian for me), but for LAD we have the same.

2017-04-08 19-57-03 PLCOpenEditor - ~Example~.png 
Quote 0 0
skv
Viacheslav, sorry. I don't use and work with OpenPLC.
I've just tried PLCOpenEditor from Beremiz. No issues on GNU/Linux and Windows 7 (amd64) with Russian/English localization. At least I can't reproduce your problem.
OpenPLC is using PLCOpenEditor from Beremiz project, but I don't know what Thiago does and how does it pack for his OpenPLC releases.

I can only fix problems in Beremiz, if I could reproduce. But this seems a little bit of topic here. If you have any further questions and problems with Beremiz, I think it's better to switch to mailing list.

Quote 0 0
thiagoralves
Skv, the version I made available on the website (PLCopen Editor 1.2) is an exact clone of your repository from 1 week ago, with no changes. The only thing that is not in your repository is the Python tools that I got from the Beremiz installer to be able to launch the Python code.

I also couldn't reproduce this problem in any Windows or Linux flavor I've tried (Windows 7, 10, Ubuntu, Kali, Debian, etc...)

Uni, when you download PLCopen Editor and opens it, by default it already appears like that? Have you tried to open the Hello World project from the website? Still the same problem?
Quote 0 0
skv
Viacheslav, I think I could reproduce and fix your problem. Fixed OpenPLCEditor you can find here https://bitbucket.org/skvorl/beremiz.
Quote 0 0
uni
See video: https://youtu.be/o9_zJAjctNk
Quote 0 0
skv
Very strange. Did the same, no problem.

First could you try Beremiz installer from http://www.beremiz.org/. Does it work for you?
Quote 0 0
uni
With installer it works fine.

2017-04-12_12-14-43.png 
Quote 0 0
skv
Good.
Could you try now latest version of the editor? To do that update (overwrite) "C:\Program files (x86\Beremiz\beremiz\" with content of my repository. This will bring you to the latest version of Beremiz editor.
Quote 0 0
uni
As I see you both use the same versions


G:\Дистрибутивы\PLC Open Editor\PLCopen Editor\Python>"G:\Дистрибутивы\PLC Open Editor\PLCopen Editor\Python\python.exe"
Python 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> ^Z

C:\Program Files (x86)\Beremiz\python>"C:\Program Files (x86)\Beremiz\python\python.exe"
Python 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> ^Z

site-packages folder looks identical.
Quote 0 0
uni
I used folder with the cyrillic name (G:\Дистрибутивы\PLC Open Editor). I think that was the problem.
Quote 0 0
skv
Probably. I'll look at the issue later. Feel free to submit ticket at https://bitbucket.org/skvorl/beremiz/issues?status=new&status=open
Quote 0 0
skv
uni, I fixed the issue with running Beremiz from directory with non-latin characters in the path. Should work now. Thanks for pointing this.
Quote 0 0