kiwitech
Just installed on Windows 10 64bit, start_runtime.cmd would appear and disappear.
With a bit of fiddling, I managed to run it so I could see what was happening, and it would seem that the attempt to run ./start_ openplc.sh is failing as the file cannot be found as it doesn't exist.

I ran the rebase script, but the file does not get created.

Quote 0 0
kiwitech
Further to this, I have narrowed it down to the install.sh script, when it calls autogen.sh at line 2 of that script it wants to run autoreconf but cannot find the file, so the script aborts and installation is not completed.
Quote 0 0
thiagoralves
It seems that you have a corrupt installation. The first steps of the installer is to get from the internet all the files and packages needed to run OpenPLC. Perhaps you have a proxy that is blocking the installer from getting those packets or something else happened when the installer was trying to download them. I suggest you just remove your current installation and try again from scratch.
Quote 0 0
kiwitech
I followed your advise, uninstalled and reinstalled, same issue at exact same place. I tried again on another machine, this time I recorded the installation, and same issue, exact same place. The install gets to [LIBMODBUS] and reports ./autogen.sh: line 2: autoreconf: command not found. This aborts the intall, it then runs "Rebasing OpenPLC Installation", gets to [LIBMODBUS] and fails.

I am on a 100MB Fibre connection with no proxy.
Recording of the install is here:
https://goo.gl/4J6pYY
Quote 0 0
thiagoralves
This is weird. I watched your installation and apparently everything goes well. It installs automake, autoconf, and libtool with no errors. But then when Libmodbus is going to use them, it says that they were not installed. The only thing I can think of right now is user permissions. Did you try installing it on the default folder (C:\Users\[Your Username]\OpenPLC)? This is usually a safe place to put things that require read/write access. Other suggestion would be to install it with admin privileges. Just right click on the installer and select "Run as Administrator"

edit: I just ran the installer on a 64-bit Windows 10 system to check if there was anything wrong with the setup, but all went fine and OpenPLC was installed as usual.

edit2: You can also try installing OpenPLC manually over Cygwin. Just go to  https://cygwin.com/install.html and download the setup file. Then on command prompt launch the setup with the following arguments:

setup-x86_64.exe -q -P git

This will install Cygwin with git package in it. After the installation is finished, open Cygwin Terminal from the start menu and type:

git clone https://github.com/thiagoralves/OpenPLC_v3.git
cd OpenPLC_v3
./install.sh win

If the installation ends up well, to start the runtime you just need to type

./start_openplc.sh
Quote 0 0
kiwitech
Thanks for that, I tried again on my IPC programming PC using the 32bit package, and same issue. I followed your edit2 advise, and apart from having to install flask and flask_login, it is now working.
Quote 0 0
ramon2130
Hi, PLC programmer here trying to develop some virtual PLC for R&D and testing environments without the need of any physical hardware. My computer runs on Windows 7 Pro & I'm also getting the "start_ openplc.sh" No such file or directory error. Im following the steps from the edit#2 advice. Can someone elaborate on how to get flask & flask_login installed?
Quote 0 0
thiagoralves
Your issue could be different than kiwitech's. Post here your installer log. It is located at your OpenPLC installation folder (usually C:\Users\[your username]\OpenPLC) inside Runtime\home\[your username]\OpenPLC_v3\installer_log.txt.
Quote 0 0
ramon2130
This are the contents of the requested log:

Installing OpenPLC on WindowsPackage lynx is already installed, skippingPackage wget is already installed, skippingPackage gcc-core is already installed, skippingPackage gcc-g++ is already installed, skippingPackage git is already installed, skippingPackage pkg-config is already installed, skippingPackage automake is already installed, skippingPackage autoconf is already installed, skippingPackage libtool is already installed, skippingPackage make is already installed, skippingPackage python2 is already installed, skippingPackage python2-pip is already installed, skippingPackage sqlite3 is already installed, skipping./background_installer.sh: line 146: pip: command not found./background_installer.sh: line 147: pip: command not found./background_installer.sh: line 148: pip: command not found[MATIEC COMPILER][ST OPTIMIZER]./background_installer.sh: line 162: g++: command not foundcp: cannot stat './st_optimizer.exe': No such file or directoryError compiling ST OptimizerOpenPLC was NOT installed!
Quote 0 0
thiagoralves
Thanks for your log! I think I’m finally nailing down the problem of why some people are having issues with the installation. I made some changes on the OpenPLC install script (if you’re curious, here are the changes:  https://github.com/thiagoralves/OpenPLC_v3/commit/11b6532fd675b1333b42b4f56d28172d01ed2b27 ).

Do you mind trying to rebase again? If it fails, can you post the new log here please?
Quote 0 0
ramon2130

I ran "Rebase OpenPLC", then I attempted to open the runtime and I get the same error "start_openplc.sh"

This is what the log looks like now:

Installing OpenPLC on Windows
--14:27:41-- http://cygwin.mirror.constant.com//x86_64/setup.bz2
=> `setup.bz2'
Resolving cygwin.mirror.constant.com... done.
Connecting to cygwin.mirror.constant.com[108.61.5.83]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,872,601 [application/octet-stream]

0K .......... .......... .......... .......... .......... 1% 406.50 KB/s
50K .......... .......... .......... .......... .......... 2% 943.40 KB/s
100K .......... .......... .......... .......... .......... 3% 1.40 MB/s
150K .......... .......... .......... .......... .......... 5% 1.81 MB/s
200K .......... .......... .......... .......... .......... 6% 2.87 MB/s
250K .......... .......... .......... .......... .......... 7% 2.12 MB/s
300K .......... .......... .......... .......... .......... 9% 2.44 MB/s
350K .......... .......... .......... .......... .......... 10% 4.88 MB/s
400K .......... .......... .......... .......... .......... 11% 3.26 MB/s
450K .......... .......... .......... .......... .......... 13% 2.22 MB/s
500K .......... .......... .......... .......... .......... 14% 4.88 MB/s
550K .......... .......... .......... .......... .......... 15% 6.98 MB/s
600K .......... .......... .......... .......... .......... 17% 4.44 MB/s
650K .......... .......... .......... .......... .......... 18% 1.95 MB/s
700K .......... .......... .......... .......... .......... 19% 4.88 MB/s
750K .......... .......... .......... .......... .......... 21% 6.98 MB/s
800K .......... .......... .......... .......... .......... 22% 6.98 MB/s
850K .......... .......... .......... .......... .......... 23% 264.55 KB/s
900K .......... .......... .......... .......... .......... 25% 495.05 KB/s
950K .......... .......... .......... .......... .......... 26% 3.26 MB/s
1000K .......... .......... .......... .......... .......... 27% 1.04 MB/s
1050K .......... .......... .......... .......... .......... 29% 6.10 MB/s
1100K .......... .......... .......... .......... .......... 30% 666.67 KB/s
1150K .......... .......... .......... .......... .......... 31% 9.77 MB/s
1200K .......... .......... .......... .......... .......... 33% 12.21 MB/s
1250K .......... .......... .......... .......... .......... 34% 12.21 MB/s
1300K .......... .......... .......... .......... .......... 35% 480.77 KB/s
1350K .......... .......... .......... .......... .......... 37% 12.21 MB/s
1400K .......... .......... .......... .......... .......... 38% 9.77 MB/s
1450K .......... .......... .......... .......... .......... 39% 12.21 MB/s
1500K .......... .......... .......... .......... .......... 40% 12.21 MB/s
1550K .......... .......... .......... .......... .......... 42% 9.77 MB/s
1600K .......... .......... .......... .......... .......... 43% 595.24 KB/s
1650K .......... .......... .......... .......... .......... 44% 4.44 MB/s
1700K .......... .......... .......... .......... .......... 46% 12.21 MB/s
1750K .......... .......... .......... .......... .......... 47% 12.21 MB/s
1800K .......... .......... .......... .......... .......... 48% 9.77 MB/s
1850K .......... .......... .......... .......... .......... 50% 581.40 KB/s
1900K .......... .......... .......... .......... .......... 51% 9.77 MB/s
1950K .......... .......... .......... .......... .......... 52% 12.21 MB/s
2000K .......... .......... .......... .......... .......... 54% 12.21 MB/s
2050K .......... .......... .......... .......... .......... 55% 9.77 MB/s
2100K .......... .......... .......... .......... .......... 56% 12.21 MB/s
2150K .......... .......... .......... .......... .......... 58% 12.21 MB/s
2200K .......... .......... .......... .......... .......... 59% 617.28 KB/s
2250K .......... .......... .......... .......... .......... 60% 9.77 MB/s
2300K .......... .......... .......... .......... .......... 62% 12.21 MB/s
2350K .......... .......... .......... .......... .......... 63% 12.21 MB/s
2400K .......... .......... .......... .......... .......... 64% 9.77 MB/s
2450K .......... .......... .......... .......... .......... 66% 12.21 MB/s
2500K .......... .......... .......... .......... .......... 67% 5.43 MB/s
2550K .......... .......... .......... .......... .......... 68% 6.10 MB/s
2600K .......... .......... .......... .......... .......... 70% 2.57 MB/s
2650K .......... .......... .......... .......... .......... 71% 5.43 MB/s
2700K .......... .......... .......... .......... .......... 72% 5.43 MB/s
2750K .......... .......... .......... .......... .......... 74% 4.88 MB/s
2800K .......... .......... .......... .......... .......... 75% 4.88 MB/s
2850K .......... .......... .......... .......... .......... 76% 4.88 MB/s
2900K .......... .......... .......... .......... .......... 78% 5.43 MB/s
2950K .......... .......... .......... .......... .......... 79% 4.88 MB/s
3000K .......... .......... .......... .......... .......... 80% 5.43 MB/s
3050K .......... .......... .......... .......... .......... 81% 5.43 MB/s
3100K .......... .......... .......... .......... .......... 83% 4.88 MB/s
3150K .......... .......... .......... .......... .......... 84% 5.43 MB/s
3200K .......... .......... .......... .......... .......... 85% 378.79 KB/s
3250K .......... .......... .......... .......... .......... 87% 12.21 MB/s
3300K .......... .......... .......... .......... .......... 88% 3.49 MB/s
3350K .......... .......... .......... .......... .......... 89% 8.14 MB/s
3400K .......... .......... .......... .......... .......... 91% 12.21 MB/s
3450K .......... .......... .......... .......... .......... 92% 9.77 MB/s
3500K .......... .......... .......... .......... .......... 93% 12.21 MB/s
3550K .......... .......... .......... .......... .......... 95% 12.21 MB/s
3600K .......... .......... .......... .......... .......... 96% 9.77 MB/s
3650K .......... .......... .......... .......... .......... 97% 12.21 MB/s
3700K .......... .......... .......... .......... .......... 99% 12.21 MB/s
3750K .......... .......... .......... . 100% 10.36 MB/s

14:27:43 (2.24 MB/s) - `setup.bz2' saved [3872601/3872601]

Updated setup.ini
Package lynx is already installed, skipping
Removing wget
rmdir: failed to remove '/usr/bin/'
Package wget removed
Removing gcc-core
Package gcc-core removed
Removing gcc-g++
Package gcc-g++ removed
Removing git
rmdir: failed to remove '/usr/bin/'
Package git removed
Removing pkg-config
Package pkg-config removed
Removing automake
rmdir: failed to remove '/usr/bin/'
Package automake removed
Removing autoconf
Package autoconf removed
Removing libtool
rmdir: failed to remove '/usr/bin/'
Package libtool removed
Removing make
rmdir: failed to remove '/usr/bin/'
Package make removed
Removing python2
Package python2 removed
Removing python2-pip
Package python2-pip removed
Removing sqlite3
Package sqlite3 removed
Installing wget
wget-1.19.1-2.tar.xz: OK
Unpacking...
Package wget requires the following packages, installing:
cygwin libgnutls28 libgnutls30 libiconv2 libidn2_0 libintl8 libnettle4 libnettle6 libpcre1 libpsl5 libuuid1 zlib0
Package cygwin is already installed, skipping
Package libgnutls28 is already installed, skipping
Package libgnutls30 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libidn2_0 is already installed, skipping
Package libintl8 is already installed, skipping
Package libnettle4 is already installed, skipping
Package libnettle6 is already installed, skipping
Package libpcre1 is already installed, skipping
Package libpsl5 is already installed, skipping
Package libuuid1 is already installed, skipping
Package zlib0 is already installed, skipping
Running /etc/postinstall/ wget.sh
Package wget installed

Installing gcc-core
gcc-core-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/x86_64-pc-cygwin-gcc-7.4.0.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ar.exe: Cannot hard link to ‘usr/bin/gcc-ar.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-nm.exe: Cannot hard link to ‘usr/bin/gcc-nm.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ranlib.exe: Cannot hard link to ‘usr/bin/gcc-ranlib.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-core requires the following packages, installing:
bash binutils cygwin cygwin-devel libatomic1 libgcc1 libgmp10 libgomp1 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libquadmath0 w32api-headers w32api-runtime windows-default-manifest zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package cygwin-devel is already installed, skipping
Package libatomic1 is already installed, skipping
Package libgcc1 is already installed, skipping
Package libgmp10 is already installed, skipping
Package libgomp1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libquadmath0 is already installed, skipping
Package w32api-headers is already installed, skipping
Package w32api-runtime is already installed, skipping
Package windows-default-manifest is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-core installed

Installing gcc-g++
gcc-g++-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-c++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-g++ requires the following packages, installing:
cygwin gcc-core libgmp10 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libstdc++6 zlib0
Package cygwin is already installed, skipping
Package gcc-core is already installed, skipping
Package libgmp10 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libstdc++6 is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-g++ installed

Installing git
--2019-06-11 08:28:47-- http://cygwin.mirror.constant.com//x86_64/release/git/git-2.21.0-1.tar.xz
Resolving cygwin.mirror.constant.com (cygwin.mirror.constant.com)... 108.61.5.83
Connecting to cygwin.mirror.constant.com (cygwin.mirror.constant.com)|108.61.5.83|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6693860 (6.4M) [application/octet-stream]
Saving to: ‘git-2.21.0-1.tar.xz’

0K .......... .......... .......... .......... .......... 0% 395K 16s
50K .......... .......... .......... .......... .......... 1% 859K 12s
100K .......... .......... .......... .......... .......... 2% 1.39M 9s
150K .......... .......... .......... .......... .......... 3% 1.75M 8s
200K .......... .......... .......... .......... .......... 3% 2.68M 7s
250K .......... .......... .......... .......... .......... 4% 1.71M 6s
300K .......... .......... .......... .......... .......... 5% 2.68M 6s
350K .......... .......... .......... .......... .......... 6% 4.87M 5s
400K .......... .......... .......... .......... .......... 6% 3.14M 5s
450K .......... .......... .......... .......... .......... 7% 1.82M 4s
500K .......... .......... .......... .......... .......... 8% 5.48M 4s
550K .......... .......... .......... .......... .......... 9% 3.83M 4s
600K .......... .......... .......... .......... .......... 9% 144K 7s
650K .......... .......... .......... .......... .......... 10% 794K 7s
700K .......... .......... .......... .......... .......... 11% 832K 7s
750K .......... .......... .......... .......... .......... 12% 6.36M 6s
800K .......... .......... .......... .......... .......... 13% 956K 6s
850K .......... .......... .......... .......... .......... 13% 6.07M 6s
900K .......... .......... .......... .......... .......... 14% 6.67M 5s
950K .......... .......... .......... .......... .......... 15% 7.43M 5s
1000K .......... .......... .......... .......... .......... 16% 2.01M 5s
1050K .......... .......... .......... .......... .......... 16% 3.06M 5s
1100K .......... .......... .......... .......... .......... 17% 6.71M 5s
1150K .......... .......... .......... .......... .......... 18% 6.32M 4s
1200K .......... .......... .......... .......... .......... 19% 195K 5s
1250K .......... .......... .......... .......... .......... 19% 767K 5s
1300K .......... .......... .......... .......... .......... 20% 818K 5s
1350K .......... .......... .......... .......... .......... 21% 907K 5s
1400K .......... .......... .......... .......... .......... 22% 7.30M 5s
1450K .......... .......... .......... .......... .......... 22% 5.94M 5s
1500K .......... .......... .......... .......... .......... 23% 194K 5s
1550K .......... .......... .......... .......... .......... 24% 857K 5s
1600K .......... .......... .......... .......... .......... 25% 6.00M 5s
1650K .......... .......... .......... .......... .......... 26% 859K 5s
1700K .......... .......... .......... .......... .......... 26% 881K 5s
1750K .......... .......... .......... .......... .......... 27% 875K 5s
1800K .......... .......... .......... .......... .......... 28% 5.62M 5s
1850K .......... .......... .......... .......... .......... 29% 872K 5s
1900K .......... .......... .......... .......... .......... 29% 877K 5s
1950K .......... .......... .......... .......... .......... 30% 9.05M 5s
2000K .......... .......... .......... .......... .......... 31% 11.0M 5s
2050K .......... .......... .......... .......... .......... 32% 930K 4s
2100K .......... .......... .......... .......... .......... 32% 6.48M 4s
2150K .......... .......... .......... .......... .......... 33% 424K 4s
2200K .......... .......... .......... .......... .......... 34% 8.77M 4s
2250K .......... .......... .......... .......... .......... 35% 10.9M 4s
2300K .......... .......... .......... .......... .......... 35% 2.44M 4s
2350K .......... .......... .......... .......... .......... 36% 10.3M 4s
2400K .......... .......... .......... .......... .......... 37% 11.2M 4s
2450K .......... .......... .......... .......... .......... 38% 11.1M 4s
2500K .......... .......... .......... .......... .......... 39% 2.48M 4s
2550K .......... .......... .......... .......... .......... 39% 11.8M 4s
2600K .......... .......... .......... .......... .......... 40% 11.8M 3s
2650K .......... .......... .......... .......... .......... 41% 1.04M 3s
2700K .......... .......... .......... .......... .......... 42% 68.2M 3s
2750K .......... .......... .......... .......... .......... 42% 14.3M 3s
2800K .......... .......... .......... .......... .......... 43% 11.7M 3s
2850K .......... .......... .......... .......... .......... 44% 11.1M 3s
2900K .......... .......... .......... .......... .......... 45% 12.2M 3s
2950K .......... .......... .......... .......... .......... 45% 11.2M 3s
3000K .......... .......... .......... .......... .......... 46% 6.27M 3s
3050K .......... .......... .......... .......... .......... 47% 5.58M 3s
3100K .......... .......... .......... .......... .......... 48% 5.73M 3s
3150K .......... .......... .......... .......... .......... 48% 5.29M 3s
3200K .......... .......... .......... .......... .......... 49% 5.77M 2s
3250K .......... .......... .......... .......... .......... 50% 6.42M 2s
3300K .......... .......... .......... .......... .......... 51% 6.30M 2s
3350K .......... .......... .......... .......... .......... 52% 6.59M 2s
3400K .......... .......... .......... .......... .......... 52% 6.09M 2s
3450K .......... .......... .......... .......... .......... 53% 6.28M 2s
3500K .......... .......... .......... .......... .......... 54% 6.41M 2s
3550K .......... .......... .......... .......... .......... 55% 6.29M 2s
3600K .......... .......... .......... .......... .......... 55% 6.62M 2s
3650K .......... .......... .......... .......... .......... 56% 6.42M 2s
3700K .......... .......... .......... .......... .......... 57% 6.16M 2s
3750K .......... .......... .......... .......... .......... 58% 6.38M 2s
3800K .......... .......... .......... .......... .......... 58% 4.56M 2s
3850K .......... .......... .......... .......... .......... 59% 5.56M 2s
3900K .......... .......... .......... .......... .......... 60% 6.77M 2s
3950K .......... .......... .......... .......... .......... 61% 5.83M 2s
4000K .......... .......... .......... .......... .......... 61% 6.23M 2s
4050K .......... .......... .......... .......... .......... 62% 6.24M 2s
4100K .......... .......... .......... .......... .......... 63% 6.37M 1s
4150K .......... .......... .......... .......... .......... 64% 6.71M 1s
4200K .......... .......... .......... .......... .......... 65% 6.23M 1s
4250K .......... .......... .......... .......... .......... 65% 6.01M 1s
4300K .......... .......... .......... .......... .......... 66% 6.72M 1s
4350K .......... .......... .......... .......... .......... 67% 6.56M 1s
4400K .......... .......... .......... .......... .......... 68% 6.26M 1s
4450K .......... .......... .......... .......... .......... 68% 5.94M 1s
4500K .......... .......... .......... .......... .......... 69% 6.46M 1s
4550K .......... .......... .......... .......... .......... 70% 5.92M 1s
4600K .......... .......... .......... .......... .......... 71% 5.49M 1s
4650K .......... .......... .......... .......... .......... 71% 5.62M 1s
4700K .......... .......... .......... .......... .......... 72% 5.82M 1s
4750K .......... .......... .......... .......... .......... 73% 6.14M 1s
4800K .......... .......... .......... .......... .......... 74% 5.42M 1s
4850K .......... .......... .......... .......... .......... 74% 5.89M 1s
4900K .......... .......... .......... .......... .......... 75% 7.24M 1s
4950K .......... .......... .......... .......... .......... 76% 6.36M 1s
5000K .......... .......... .......... .......... .......... 77% 6.85M 1s
5050K .......... .......... .......... .......... .......... 78% 6.10M 1s
5100K .......... .......... .......... .......... .......... 78% 6.56M 1s
5150K .......... .......... .......... .......... .......... 79% 6.41M 1s
5200K .......... .......... .......... .......... .......... 80% 6.61M 1s
5250K .......... .......... .......... .......... .......... 81% 6.25M 1s
5300K .......... .......... .......... .......... .......... 81% 6.91M 1s
5350K .......... .......... .......... .......... .......... 82% 6.37M 1s
5400K .......... .......... .......... .......... .......... 83% 6.40M 1s
5450K .......... .......... .......... .......... .......... 84% 6.57M 1s
5500K .......... .......... .......... .......... .......... 84% 6.30M 0s
5550K .......... .......... .......... .......... .......... 85% 6.63M 0s
5600K .......... .......... .......... .......... .......... 86% 6.58M 0s
5650K .......... .......... .......... .......... .......... 87% 6.40M 0s
5700K .......... .......... .......... .......... .......... 87% 6.59M 0s
5750K .......... .......... .......... .......... .......... 88% 6.40M 0s
5800K .......... .......... .......... .......... .......... 89% 6.70M 0s
5850K .......... .......... .......... .......... .......... 90% 6.39M 0s
5900K .......... .......... .......... .......... .......... 91% 6.39M 0s
5950K .......... .......... .......... .......... .......... 91% 6.35M 0s
6000K .......... .......... .......... .......... .......... 92% 6.67M 0s
6050K .......... .......... .......... .......... .......... 93% 6.28M 0s
6100K .......... .......... .......... .......... .......... 94% 6.83M 0s
6150K .......... .......... .......... .......... .......... 94% 6.30M 0s
6200K .......... .......... .......... .......... .......... 95% 6.74M 0s
6250K .......... .......... .......... .......... .......... 96% 6.41M 0s
6300K .......... .......... .......... .......... .......... 97% 6.32M 0s
6350K .......... .......... .......... .......... .......... 97% 307K 0s
6400K .......... .......... .......... .......... .......... 98% 11.9M 0s
6450K .......... .......... .......... .......... .......... 99% 10.9M 0s
6500K .......... .......... .......... ...... 100% 11.4M=3.1s

2019-06-11 08:28:50 (2.06 MB/s) - ‘git-2.21.0-1.tar.xz’ saved [6693860/6693860]

git-2.21.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/git-upload-archive.exe: Cannot hard link to ‘usr/bin/git-receive-pack.exe’: Permission denied
tar: usr/bin/git-upload-pack.exe: Cannot hard link to ‘usr/bin/git-receive-pack.exe’: Permission denied
tar: usr/bin/git.exe: Cannot hard link to ‘usr/bin/git-receive-pack.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package git requires the following packages, installing:
bash cygutils cygwin less libcurl4 libexpat1 libiconv2 libintl8 libopenssl100 libpcre1 libssl1.1 openssh perl-Error perl-Scalar-List-Utils perl-TermReadKey perl_base rsync zlib0
Package bash is already installed, skipping
Package cygutils is already installed, skipping
Package cygwin is already installed, skipping
Package less is already installed, skipping
Package libcurl4 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libpcre1 is already installed, skipping
Package libssl1.1 is already installed, skipping
Package openssh is already installed, skipping
Package perl-Error is already installed, skipping
Installing perl-Scalar-List-Utils
--2019-06-11 08:28:53-- http://cygwin.mirror.constant.com//x86_64/release/perl-Scalar-List-Utils/perl-Scalar-List-Utils-1.50-1.tar.xz
Resolving cygwin.mirror.constant.com (cygwin.mirror.constant.com)... 108.61.5.83
Connecting to cygwin.mirror.constant.com (cygwin.mirror.constant.com)|108.61.5.83|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 50164 (49K) [application/octet-stream]
Saving to: ‘perl-Scalar-List-Utils-1.50-1.tar.xz’

0K .......... .......... .......... .......... ........ 100% 374K=0.1s

2019-06-11 08:28:53 (374 KB/s) - ‘perl-Scalar-List-Utils-1.50-1.tar.xz’ saved [50164/50164]

perl-Scalar-List-Utils-1.50-1.tar.xz: OK
Unpacking...
Package perl-Scalar-List-Utils requires the following packages, installing:
cygwin libssp0 perl perl_base
Package cygwin is already installed, skipping
Package libssp0 is already installed, skipping
Package perl is already installed, skipping
Package perl_base is already installed, skipping
Package perl-TermReadKey is already installed, skipping
Package perl_base is already installed, skipping
Package rsync is already installed, skipping
Package zlib0 is already installed, skipping
Package git installed

Installing pkg-config
pkg-config-1.6.0-1.tar.xz: OK
Unpacking...
Package pkg-config requires the following packages, installing:
bash cygwin libglib2.0_0 pkgconf
Package bash is already installed, skipping
Package cygwin is already installed, skipping
Package libglib2.0_0 is already installed, skipping
Package pkgconf is already installed, skipping
Package pkg-config installed

Installing automake
automake-10-1.tar.xz: OK
Unpacking...
Package automake requires the following packages, installing:
automake1.10 automake1.11 automake1.12 automake1.13 automake1.14 automake1.15 automake1.4 automake1.5 automake1.6 automake1.7 automake1.8 automake1.9 bash gawk
Package automake1.10 is already installed, skipping
Package automake1.11 is already installed, skipping
Package automake1.12 is already installed, skipping
Package automake1.13 is already installed, skipping
Package automake1.14 is already installed, skipping
Package automake1.15 is already installed, skipping
Package automake1.4 is already installed, skipping
Package automake1.5 is already installed, skipping
Package automake1.6 is already installed, skipping
Package automake1.7 is already installed, skipping
Package automake1.8 is already installed, skipping
Package automake1.9 is already installed, skipping
Package bash is already installed, skipping
Package gawk is already installed, skipping
Package automake installed

Installing autoconf
autoconf-13-1.tar.bz2: OK
Unpacking...
Package autoconf requires the following packages, installing:
autoconf2.1 autoconf2.5 bash sed
Package autoconf2.1 is already installed, skipping
Package autoconf2.5 is already installed, skipping
Package bash is already installed, skipping
Package sed is already installed, skipping
Running /etc/postinstall/ autoconf.sh
Package autoconf installed

Installing libtool
libtool-2.4.6-6.tar.xz: OK
Unpacking...
Package libtool requires the following packages, installing:
bash libltdl7
Package bash is already installed, skipping
Package libltdl7 is already installed, skipping
Package libtool installed

Installing make
make-4.2.1-2.tar.xz: OK
Unpacking...
Package make requires the following packages, installing:
cygwin libguile17 libguile2.0_22 libintl8
Package cygwin is already installed, skipping
Package libguile17 is already installed, skipping
Package libguile2.0_22 is already installed, skipping
Package libintl8 is already installed, skipping
Package make installed

Installing python2
python2-2.7.16-1.tar.xz: OK
Unpacking...
Package python2 requires the following packages, installing:
bash binutils cygwin libbz2_1 libcrypt0 libdb5.3 libexpat1 libffi6 libgdbm4 libintl8 libncursesw10 libopenssl100 libreadline7 libsqlite3_0 libuuid-devel python27 zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package libbz2_1 is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libffi6 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libintl8 is already installed, skipping
Package libncursesw10 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package libuuid-devel is already installed, skipping
Package python27 is already installed, skipping
Package zlib0 is already installed, skipping
Package python2 installed

Installing python2-pip
python2-pip-19.0.3-1.tar.xz: OK
Unpacking...
Package python2-pip requires the following packages, installing:
python2 python2-appdirs python2-ipaddress python2-lockfile python2-lxml python2-packaging python2-pyparsing python2-requests python2-setuptools python2-six python2-wheel python27-pip
Package python2 is already installed, skipping
Package python2-appdirs is already installed, skipping
Package python2-ipaddress is already installed, skipping
Package python2-lockfile is already installed, skipping
Package python2-lxml is already installed, skipping
Package python2-packaging is already installed, skipping
Package python2-pyparsing is already installed, skipping
Package python2-requests is already installed, skipping
Package python2-setuptools is already installed, skipping
Package python2-six is already installed, skipping
Package python2-wheel is already installed, skipping
Package python27-pip is already installed, skipping
Package python2-pip installed

Installing sqlite3
sqlite3-3.28.0-1.tar.xz: OK
Unpacking...
Package sqlite3 requires the following packages, installing:
cygwin libreadline7 libsqlite3_0 sqlite3-vfslog
Package cygwin is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package sqlite3-vfslog is already installed, skipping
Package sqlite3 installed
./background_installer.sh: line 148: pip: command not found
./background_installer.sh: line 149: pip: command not found
./background_installer.sh: line 150: pip: command not found

[MATIEC COMPILER]

[ST OPTIMIZER]
./background_installer.sh: line 164: g++: command not found
cp: cannot stat './st_optimizer.exe': No such file or directory
Error compiling ST Optimizer
OpenPLC was NOT installed!

Quote 0 0
thiagoralves
You are getting a bunch of permission denied errors. Try running the Rebase OpenPLC as Administrator (right click on the link -> run as Administrator)
Quote 0 0
ramon2130

I logged into my computer using the local administrator account. Installed the runtime software and upon launching received the same error "start_openplc.sh". I tried to rebase, as far as I can tell the rebase works but I still see Permission Denied errors on the log. I tried the rebase with a right click and Run as Administrator, same result, not working yet.

Log:

Installing OpenPLC on Windows
--19:25:35-- http://cygwin.mirror.constant.com//x86_64/setup.bz2
=> `setup.bz2'
Resolving cygwin.mirror.constant.com... done.
Connecting to cygwin.mirror.constant.com[108.61.5.83]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,872,601 [application/octet-stream]

0K .......... .......... .......... .......... .......... 1% 390.63 KB/s
50K .......... .......... .......... .......... .......... 2% 961.54 KB/s
100K .......... .......... .......... .......... .......... 3% 1.36 MB/s
150K .......... .......... .......... .......... .......... 5% 1.81 MB/s
200K .......... .......... .......... .......... .......... 6% 2.57 MB/s
250K .......... .......... .......... .......... .......... 7% 2.03 MB/s
300K .......... .......... .......... .......... .......... 9% 2.12 MB/s
350K .......... .......... .......... .......... .......... 10% 4.88 MB/s
400K .......... .......... .......... .......... .......... 11% 5.43 MB/s
450K .......... .......... .......... .......... .......... 13% 2.71 MB/s
500K .......... .......... .......... .......... .......... 14% 2.44 MB/s
550K .......... .......... .......... .......... .......... 15% 6.10 MB/s
600K .......... .......... .......... .......... .......... 17% 6.10 MB/s
650K .......... .......... .......... .......... .......... 18% 6.10 MB/s
700K .......... .......... .......... .......... .......... 19% 2.33 MB/s
750K .......... .......... .......... .......... .......... 21% 2.87 MB/s
800K .......... .......... .......... .......... .......... 22% 6.10 MB/s
850K .......... .......... .......... .......... .......... 23% 6.98 MB/s
900K .......... .......... .......... .......... .......... 25% 140.45 KB/s
950K .......... .......... .......... .......... .......... 26% 416.67 KB/s
1000K .......... .......... .......... .......... .......... 27% 6.98 MB/s
1050K .......... .......... .......... .......... .......... 29% 909.09 KB/s
1100K .......... .......... .......... .......... .......... 30% 6.10 MB/s
1150K .......... .......... .......... .......... .......... 31% 362.32 KB/s
1200K .......... .......... .......... .......... .......... 33% 1.68 MB/s
1250K .......... .......... .......... .......... .......... 34% 9.77 MB/s
1300K .......... .......... .......... .......... .......... 35% 12.21 MB/s
1350K .......... .......... .......... .......... .......... 37% 2.22 MB/s
1400K .......... .......... .......... .......... .......... 38% 12.21 MB/s
1450K .......... .......... .......... .......... .......... 39% 12.21 MB/s
1500K .......... .......... .......... .......... .......... 40% 9.77 MB/s
1550K .......... .......... .......... .......... .......... 42% 2.71 MB/s
1600K .......... .......... .......... .......... .......... 43% 9.77 MB/s
1650K .......... .......... .......... .......... .......... 44% 1.81 MB/s
1700K .......... .......... .......... .......... .......... 46% 6.98 MB/s
1750K .......... .......... .......... .......... .......... 47% 2.12 MB/s
1800K .......... .......... .......... .......... .......... 48% 6.98 MB/s
1850K .......... .......... .......... .......... .......... 50% 370.37 KB/s
1900K .......... .......... .......... .......... .......... 51% 409.84 KB/s
1950K .......... .......... .......... .......... .......... 52% 9.77 MB/s
2000K .......... .......... .......... .......... .......... 54% 909.09 KB/s
2050K .......... .......... .......... .......... .......... 55% 6.98 MB/s
2100K .......... .......... .......... .......... .......... 56% 6.10 MB/s
2150K .......... .......... .......... .......... .......... 58% 1.06 MB/s
2200K .......... .......... .......... .......... .......... 59% 6.10 MB/s
2250K .......... .......... .......... .......... .......... 60% 6.10 MB/s
2300K .......... .......... .......... .......... .......... 62% 6.10 MB/s
2350K .......... .......... .......... .......... .......... 63% 6.98 MB/s
2400K .......... .......... .......... .......... .......... 64% 2.03 MB/s
2450K .......... .......... .......... .......... .......... 66% 6.10 MB/s
2500K .......... .......... .......... .......... .......... 67% 6.98 MB/s
2550K .......... .......... .......... .......... .......... 68% 8.14 MB/s
2600K .......... .......... .......... .......... .......... 70% 6.10 MB/s
2650K .......... .......... .......... .......... .......... 71% 6.98 MB/s
2700K .......... .......... .......... .......... .......... 72% 127.88 KB/s
2750K .......... .......... .......... .......... .......... 74% 769.23 KB/s
2800K .......... .......... .......... .......... .......... 75% 819.67 KB/s
2850K .......... .......... .......... .......... .......... 76% 925.93 KB/s
2900K .......... .......... .......... .......... .......... 78% 6.98 MB/s
2950K .......... .......... .......... .......... .......... 79% 6.98 MB/s
3000K .......... .......... .......... .......... .......... 80% 6.10 MB/s
3050K .......... .......... .......... .......... .......... 81% 1.28 MB/s
3100K .......... .......... .......... .......... .......... 83% 6.98 MB/s
3150K .......... .......... .......... .......... .......... 84% 6.10 MB/s
3200K .......... .......... .......... .......... .......... 85% 6.98 MB/s
3250K .......... .......... .......... .......... .......... 87% 9.77 MB/s
3300K .......... .......... .......... .......... .......... 88% 12.21 MB/s
3350K .......... .......... .......... .......... .......... 89% 316.46 KB/s
3400K .......... .......... .......... .......... .......... 91% 12.21 MB/s
3450K .......... .......... .......... .......... .......... 92% 12.21 MB/s
3500K .......... .......... .......... .......... .......... 93% 12.21 MB/s
3550K .......... .......... .......... .......... .......... 95% 9.77 MB/s
3600K .......... .......... .......... .......... .......... 96% 12.21 MB/s
3650K .......... .......... .......... .......... .......... 97% 12.21 MB/s
3700K .......... .......... .......... .......... .......... 99% 12.21 MB/s
3750K .......... .......... .......... . 100% 1.00 MB/s

19:25:38 (1.40 MB/s) - `setup.bz2' saved [3872601/3872601]

Updated setup.ini
Package lynx is already installed, skipping
Removing gcc-core
Package gcc-core removed
Removing gcc-g++
Package gcc-g++ removed
Removing pkg-config
Package pkg-config removed
Removing automake
rmdir: failed to remove '/usr/bin/'
Package automake removed
Removing autoconf
Package autoconf removed
Removing libtool
rmdir: failed to remove '/usr/bin/'
Package libtool removed
Removing make
rmdir: failed to remove '/usr/bin/'
Package make removed
Removing python2
Package python2 removed
Removing python2-pip
Package python2-pip removed
Removing sqlite3
Package sqlite3 removed
Package wget is already installed, skipping
Installing gcc-core
gcc-core-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/x86_64-pc-cygwin-gcc-7.4.0.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ar.exe: Cannot hard link to ‘usr/bin/gcc-ar.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-nm.exe: Cannot hard link to ‘usr/bin/gcc-nm.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ranlib.exe: Cannot hard link to ‘usr/bin/gcc-ranlib.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-core requires the following packages, installing:
bash binutils cygwin cygwin-devel libatomic1 libgcc1 libgmp10 libgomp1 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libquadmath0 w32api-headers w32api-runtime windows-default-manifest zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package cygwin-devel is already installed, skipping
Package libatomic1 is already installed, skipping
Package libgcc1 is already installed, skipping
Package libgmp10 is already installed, skipping
Package libgomp1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libquadmath0 is already installed, skipping
Package w32api-headers is already installed, skipping
Package w32api-runtime is already installed, skipping
Package windows-default-manifest is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-core installed

Installing gcc-g++
gcc-g++-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-c++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-g++ requires the following packages, installing:
cygwin gcc-core libgmp10 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libstdc++6 zlib0
Package cygwin is already installed, skipping
Package gcc-core is already installed, skipping
Package libgmp10 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libstdc++6 is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-g++ installed
Package git is already installed, skipping

Installing pkg-config
pkg-config-1.6.0-1.tar.xz: OK
Unpacking...
Package pkg-config requires the following packages, installing:
bash cygwin libglib2.0_0 pkgconf
Package bash is already installed, skipping
Package cygwin is already installed, skipping
Package libglib2.0_0 is already installed, skipping
Package pkgconf is already installed, skipping
Package pkg-config installed

Installing automake
automake-10-1.tar.xz: OK
Unpacking...
Package automake requires the following packages, installing:
automake1.10 automake1.11 automake1.12 automake1.13 automake1.14 automake1.15 automake1.4 automake1.5 automake1.6 automake1.7 automake1.8 automake1.9 bash gawk
Package automake1.10 is already installed, skipping
Package automake1.11 is already installed, skipping
Package automake1.12 is already installed, skipping
Package automake1.13 is already installed, skipping
Package automake1.14 is already installed, skipping
Package automake1.15 is already installed, skipping
Package automake1.4 is already installed, skipping
Package automake1.5 is already installed, skipping
Package automake1.6 is already installed, skipping
Package automake1.7 is already installed, skipping
Package automake1.8 is already installed, skipping
Package automake1.9 is already installed, skipping
Package bash is already installed, skipping
Package gawk is already installed, skipping
Package automake installed

Installing autoconf
autoconf-13-1.tar.bz2: OK
Unpacking...
Package autoconf requires the following packages, installing:
autoconf2.1 autoconf2.5 bash sed
Package autoconf2.1 is already installed, skipping
Package autoconf2.5 is already installed, skipping
Package bash is already installed, skipping
Package sed is already installed, skipping
Running /etc/postinstall/ autoconf.sh
Package autoconf installed

Installing libtool
libtool-2.4.6-6.tar.xz: OK
Unpacking...
Package libtool requires the following packages, installing:
bash libltdl7
Package bash is already installed, skipping
Package libltdl7 is already installed, skipping
Package libtool installed

Installing make
make-4.2.1-2.tar.xz: OK
Unpacking...
Package make requires the following packages, installing:
cygwin libguile17 libguile2.0_22 libintl8
Package cygwin is already installed, skipping
Package libguile17 is already installed, skipping
Package libguile2.0_22 is already installed, skipping
Package libintl8 is already installed, skipping
Package make installed

Installing python2
python2-2.7.16-1.tar.xz: OK
Unpacking...
Package python2 requires the following packages, installing:
bash binutils cygwin libbz2_1 libcrypt0 libdb5.3 libexpat1 libffi6 libgdbm4 libintl8 libncursesw10 libopenssl100 libreadline7 libsqlite3_0 libuuid-devel python27 zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package libbz2_1 is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libffi6 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libintl8 is already installed, skipping
Package libncursesw10 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package libuuid-devel is already installed, skipping
Package python27 is already installed, skipping
Package zlib0 is already installed, skipping
Package python2 installed

Installing python2-pip
python2-pip-19.0.3-1.tar.xz: OK
Unpacking...
Package python2-pip requires the following packages, installing:
python2 python2-appdirs python2-ipaddress python2-lockfile python2-lxml python2-packaging python2-pyparsing python2-requests python2-setuptools python2-six python2-wheel python27-pip
Package python2 is already installed, skipping
Package python2-appdirs is already installed, skipping
Package python2-ipaddress is already installed, skipping
Package python2-lockfile is already installed, skipping
Package python2-lxml is already installed, skipping
Package python2-packaging is already installed, skipping
Package python2-pyparsing is already installed, skipping
Package python2-requests is already installed, skipping
Package python2-setuptools is already installed, skipping
Package python2-six is already installed, skipping
Package python2-wheel is already installed, skipping
Package python27-pip is already installed, skipping
Package python2-pip installed

Installing sqlite3
sqlite3-3.28.0-1.tar.xz: OK
Unpacking...
Package sqlite3 requires the following packages, installing:
cygwin libreadline7 libsqlite3_0 sqlite3-vfslog
Package cygwin is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package sqlite3-vfslog is already installed, skipping
Package sqlite3 installed
./background_installer.sh: line 148: pip: command not found
./background_installer.sh: line 149: pip: command not found
./background_installer.sh: line 150: pip: command not found

[MATIEC COMPILER]

[ST OPTIMIZER]
./background_installer.sh: line 164: g++: command not found
cp: cannot stat './st_optimizer.exe': No such file or directory
Error compiling ST Optimizer
OpenPLC was NOT installed!

Quote 0 0
thiagoralves
Thanks to your logs I was able to pinpoint the problems with this installer. The root of the issue is that the installer bundles an older installation of Cygwin that fails to load the new packages that are downloaded during OpenPLC installation. I have refactored the OpenPLC Installer to be smaller, more efficient, and universal (i.e. you don't have a different version for x86 and x64 anymore). This new installer will download a fresh copy of Cygwin from the web and install it before starting the runtime install script. This will probably fix all issues people are having with the OpenPLC Installer.

If you haven't done so, please uninstall OpenPLC Runtime from your computer, go to the website ( https://www.openplcproject.com/getting-started-windows 😉 and download the new installer.
Quote 0 0
ramon2130

Im glad we are making progress but it seems we are not quite there yet. I reverted back to my regular user account. I uninstalled the old version, then downloaded the new version and ran the new installer. The runtime program still refuses to open giving me the same error, the new log:

Installing OpenPLC on Windows
--19:51:11-- http://cygwin.mirror.constant.com//x86_64/setup.bz2
=> `setup.bz2'
Resolving cygwin.mirror.constant.com... done.
Connecting to cygwin.mirror.constant.com[108.61.5.83]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,872,601 [application/octet-stream]

0K .......... .......... .......... .......... .......... 1% 396.83 KB/s
50K .......... .......... .......... .......... .......... 2% 980.39 KB/s
100K .......... .......... .......... .......... .......... 3% 1.40 MB/s
150K .......... .......... .......... .......... .......... 5% 1.53 MB/s
200K .......... .......... .......... .......... .......... 6% 3.76 MB/s
250K .......... .......... .......... .......... .......... 7% 1.68 MB/s
300K .......... .......... .......... .......... .......... 9% 2.33 MB/s
350K .......... .......... .......... .......... .......... 10% 4.88 MB/s
400K .......... .......... .......... .......... .......... 11% 4.88 MB/s
450K .......... .......... .......... .......... .......... 13% 1.68 MB/s
500K .......... .......... .......... .......... .......... 14% 4.88 MB/s
550K .......... .......... .......... .......... .......... 15% 6.10 MB/s
600K .......... .......... .......... .......... .......... 17% 6.98 MB/s
650K .......... .......... .......... .......... .......... 18% 2.87 MB/s
700K .......... .......... .......... .......... .......... 19% 2.87 MB/s
750K .......... .......... .......... .......... .......... 21% 6.10 MB/s
800K .......... .......... .......... .......... .......... 22% 6.98 MB/s
850K .......... .......... .......... .......... .......... 23% 617.28 KB/s
900K .......... .......... .......... .......... .......... 25% 232.56 KB/s
950K .......... .......... .......... .......... .......... 26% 862.07 KB/s
1000K .......... .......... .......... .......... .......... 27% 6.10 MB/s
1050K .......... .......... .......... .......... .......... 29% 1000.00 KB/s
1100K .......... .......... .......... .......... .......... 30% 6.98 MB/s
1150K .......... .......... .......... .......... .......... 31% 6.98 MB/s
1200K .......... .......... .......... .......... .......... 33% 8.14 MB/s
1250K .......... .......... .......... .......... .......... 34% 12.21 MB/s
1300K .......... .......... .......... .......... .......... 35% 1.25 MB/s
1350K .......... .......... .......... .......... .......... 37% 6.10 MB/s
1400K .......... .......... .......... .......... .......... 38% 458.72 KB/s
1450K .......... .......... .......... .......... .......... 39% 12.21 MB/s
1500K .......... .......... .......... .......... .......... 40% 6.10 MB/s
1550K .......... .......... .......... .......... .......... 42% 12.21 MB/s
1600K .......... .......... .......... .......... .......... 43% 12.21 MB/s
1650K .......... .......... .......... .......... .......... 44% 9.77 MB/s
1700K .......... .......... .......... .......... .......... 46% 1.48 MB/s
1750K .......... .......... .......... .......... .......... 47% 9.77 MB/s
1800K .......... .......... .......... .......... .......... 48% 12.21 MB/s
1850K .......... .......... .......... .......... .......... 50% 12.21 MB/s
1900K .......... .......... .......... .......... .......... 51% 9.77 MB/s
1950K .......... .......... .......... .......... .......... 52% 12.21 MB/s
2000K .......... .......... .......... .......... .......... 54% 12.21 MB/s
2050K .......... .......... .......... .......... .......... 55% 9.77 MB/s
2100K .......... .......... .......... .......... .......... 56% 1.48 MB/s
2150K .......... .......... .......... .......... .......... 58% 6.10 MB/s
2200K .......... .......... .......... .......... .......... 59% 6.10 MB/s
2250K .......... .......... .......... .......... .......... 60% 6.98 MB/s
2300K .......... .......... .......... .......... .......... 62% 5.43 MB/s
2350K .......... .......... .......... .......... .......... 63% 6.10 MB/s
2400K .......... .......... .......... .......... .......... 64% 5.43 MB/s
2450K .......... .......... .......... .......... .......... 66% 5.43 MB/s
2500K .......... .......... .......... .......... .......... 67% 6.10 MB/s
2550K .......... .......... .......... .......... .......... 68% 5.43 MB/s
2600K .......... .......... .......... .......... .......... 70% 5.43 MB/s
2650K .......... .......... .......... .......... .......... 71% 5.43 MB/s
2700K .......... .......... .......... .......... .......... 72% 5.43 MB/s
2750K .......... .......... .......... .......... .......... 74% 5.43 MB/s
2800K .......... .......... .......... .......... .......... 75% 150.15 KB/s
2850K .......... .......... .......... .......... .......... 76% 409.84 KB/s
2900K .......... .......... .......... .......... .......... 78% 819.67 KB/s
2950K .......... .......... .......... .......... .......... 79% 847.46 KB/s
3000K .......... .......... .......... .......... .......... 80% 5.43 MB/s
3050K .......... .......... .......... .......... .......... 81% 6.10 MB/s
3100K .......... .......... .......... .......... .......... 83% 1.11 MB/s
3150K .......... .......... .......... .......... .......... 84% 6.98 MB/s
3200K .......... .......... .......... .......... .......... 85% 6.98 MB/s
3250K .......... .......... .......... .......... .......... 87% 6.10 MB/s
3300K .......... .......... .......... .......... .......... 88% 6.98 MB/s
3350K .......... .......... .......... .......... .......... 89% 2.22 MB/s
3400K .......... .......... .......... .......... .......... 91% 6.10 MB/s
3450K .......... .......... .......... .......... .......... 92% 6.10 MB/s
3500K .......... .......... .......... .......... .......... 93% 12.21 MB/s
3550K .......... .......... .......... .......... .......... 95% 9.77 MB/s
3600K .......... .......... .......... .......... .......... 96% 3.76 MB/s
3650K .......... .......... .......... .......... .......... 97% 6.98 MB/s
3700K .......... .......... .......... .......... .......... 99% 393.70 KB/s
3750K .......... .......... .......... . 100% 10.36 MB/s

19:51:13 (1.74 MB/s) - `setup.bz2' saved [3872601/3872601]

Updated setup.ini
Package lynx is already installed, skipping
Removing gcc-core
Package gcc-core removed
Removing gcc-g++
Package gcc-g++ removed
Removing pkg-config
Package pkg-config removed
Removing automake
rmdir: failed to remove '/usr/bin/'
Package automake removed
Removing autoconf
Package autoconf removed
Removing libtool
rmdir: failed to remove '/usr/bin/'
Package libtool removed
Removing make
rmdir: failed to remove '/usr/bin/'
Package make removed
Removing python2
Package python2 removed
Package python2-pip is not installed, skipping
Removing sqlite3
Package sqlite3 removed
Package wget is already installed, skipping
Installing gcc-core
gcc-core-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/x86_64-pc-cygwin-gcc-7.4.0.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc.exe: Cannot hard link to ‘usr/bin/gcc.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ar.exe: Cannot hard link to ‘usr/bin/gcc-ar.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-nm.exe: Cannot hard link to ‘usr/bin/gcc-nm.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-gcc-ranlib.exe: Cannot hard link to ‘usr/bin/gcc-ranlib.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-core requires the following packages, installing:
bash binutils cygwin cygwin-devel libatomic1 libgcc1 libgmp10 libgomp1 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libquadmath0 w32api-headers w32api-runtime windows-default-manifest zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package cygwin-devel is already installed, skipping
Package libatomic1 is already installed, skipping
Package libgcc1 is already installed, skipping
Package libgmp10 is already installed, skipping
Package libgomp1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libquadmath0 is already installed, skipping
Package w32api-headers is already installed, skipping
Package w32api-runtime is already installed, skipping
Package windows-default-manifest is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-core installed

Installing gcc-g++
gcc-g++-7.4.0-1.tar.xz: OK
Unpacking...
tar: usr/bin/g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-c++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: usr/bin/x86_64-pc-cygwin-g++.exe: Cannot hard link to ‘usr/bin/c++.exe’: Permission denied
tar: Exiting with failure status due to previous errors
Package gcc-g++ requires the following packages, installing:
cygwin gcc-core libgmp10 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libstdc++6 zlib0
Package cygwin is already installed, skipping
Package gcc-core is already installed, skipping
Package libgmp10 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libstdc++6 is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-g++ installed
Package git is already installed, skipping

Installing pkg-config
pkg-config-1.6.0-1.tar.xz: OK
Unpacking...
Package pkg-config requires the following packages, installing:
bash cygwin libglib2.0_0 pkgconf
Package bash is already installed, skipping
Package cygwin is already installed, skipping
Package libglib2.0_0 is already installed, skipping
Package pkgconf is already installed, skipping
Package pkg-config installed

Installing automake
automake-10-1.tar.xz: OK
Unpacking...
Package automake requires the following packages, installing:
automake1.10 automake1.11 automake1.12 automake1.13 automake1.14 automake1.15 automake1.4 automake1.5 automake1.6 automake1.7 automake1.8 automake1.9 bash gawk
Package automake1.10 is already installed, skipping
Package automake1.11 is already installed, skipping
Package automake1.12 is already installed, skipping
Package automake1.13 is already installed, skipping
Package automake1.14 is already installed, skipping
Package automake1.15 is already installed, skipping
Package automake1.4 is already installed, skipping
Package automake1.5 is already installed, skipping
Package automake1.6 is already installed, skipping
Package automake1.7 is already installed, skipping
Package automake1.8 is already installed, skipping
Package automake1.9 is already installed, skipping
Package bash is already installed, skipping
Package gawk is already installed, skipping
Package automake installed

Installing autoconf
autoconf-13-1.tar.bz2: OK
Unpacking...
Package autoconf requires the following packages, installing:
autoconf2.1 autoconf2.5 bash sed
Package autoconf2.1 is already installed, skipping
Package autoconf2.5 is already installed, skipping
Package bash is already installed, skipping
Package sed is already installed, skipping
Running /etc/postinstall/ autoconf.sh
Package autoconf installed

Installing libtool
libtool-2.4.6-6.tar.xz: OK
Unpacking...
Package libtool requires the following packages, installing:
bash libltdl7
Package bash is already installed, skipping
Package libltdl7 is already installed, skipping
Package libtool installed

Installing make
make-4.2.1-2.tar.xz: OK
Unpacking...
Package make requires the following packages, installing:
cygwin libguile17 libguile2.0_22 libintl8
Package cygwin is already installed, skipping
Package libguile17 is already installed, skipping
Package libguile2.0_22 is already installed, skipping
Package libintl8 is already installed, skipping
Package make installed

Installing python2
python2-2.7.16-1.tar.xz: OK
Unpacking...
Package python2 requires the following packages, installing:
bash binutils cygwin libbz2_1 libcrypt0 libdb5.3 libexpat1 libffi6 libgdbm4 libintl8 libncursesw10 libopenssl100 libreadline7 libsqlite3_0 libuuid-devel python27 zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package libbz2_1 is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libffi6 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libintl8 is already installed, skipping
Package libncursesw10 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package libuuid-devel is already installed, skipping
Package python27 is already installed, skipping
Package zlib0 is already installed, skipping
Package python2 installed

Installing python2-pip
python2-pip-19.0.3-1.tar.xz: OK
Unpacking...
Package python2-pip requires the following packages, installing:
python2 python2-appdirs python2-ipaddress python2-lockfile python2-lxml python2-packaging python2-pyparsing python2-requests python2-setuptools python2-six python2-wheel python27-pip
Package python2 is already installed, skipping
Installing python2-appdirs
python2-appdirs-1.4.3-2.tar.xz: OK
Unpacking...
Package python2-appdirs requires the following packages, installing:
python2 python27-appdirs
Package python2 is already installed, skipping
Package python27-appdirs is already installed, skipping
Installing python2-ipaddress
python2-ipaddress-1.0.22-1.tar.xz: OK
Unpacking...
Package python2-ipaddress requires the following packages, installing:
python2 python27-ipaddress
Package python2 is already installed, skipping
Package python27-ipaddress is already installed, skipping
Installing python2-lockfile
python2-lockfile-0.12.2-2.tar.xz: OK
Unpacking...
Package python2-lockfile requires the following packages, installing:
python2 python27-lockfile
Package python2 is already installed, skipping
Package python27-lockfile is already installed, skipping
Installing python2-lxml
python2-lxml-4.3.2-1.tar.xz: OK
Unpacking...
Package python2-lxml requires the following packages, installing:
cygwin libxml2 libxslt python2 python27-lxml
Package cygwin is already installed, skipping
Package libxml2 is already installed, skipping
Package libxslt is already installed, skipping
Package python2 is already installed, skipping
Package python27-lxml is already installed, skipping
Installing python2-packaging
python2-packaging-19.0-1.tar.xz: OK
Unpacking...
Package python2-packaging requires the following packages, installing:
python2 python2-pyparsing python27-packaging
Package python2 is already installed, skipping
Installing python2-pyparsing
python2-pyparsing-2.3.1-1.tar.xz: OK
Unpacking...
Package python2-pyparsing requires the following packages, installing:
python2 python27-pyparsing
Package python2 is already installed, skipping
Package python27-pyparsing is already installed, skipping
Package python27-packaging is already installed, skipping
Package python2-pyparsing is already installed, skipping
Installing python2-requests
python2-requests-2.21.0-1.tar.xz: OK
Unpacking...
Package python2-requests requires the following packages, installing:
ca-certificates python2 python2-chardet python2-idna python2-urllib3 python27-requests
Package ca-certificates is already installed, skipping
Package python2 is already installed, skipping
Installing python2-chardet
python2-chardet-3.0.4-1.tar.xz: OK
Unpacking...
Package python2-chardet requires the following packages, installing:
python2 python27-chardet
Package python2 is already installed, skipping
Package python27-chardet is already installed, skipping
Installing python2-idna
python2-idna-2.8-1.tar.xz: OK
Unpacking...
Package python2-idna requires the following packages, installing:
python2 python27-idna
Package python2 is already installed, skipping
Package python27-idna is already installed, skipping
Installing python2-urllib3
python2-urllib3-1.24.1-1.tar.xz: OK
Unpacking...
Package python2-urllib3 requires the following packages, installing:
python2 python2-backports.ssl_match_hostname python2-cryptography python2-openssl python2-six python27-urllib3
Package python2 is already installed, skipping
Package python2-backports.ssl_match_hostname is already installed, skipping
Installing python2-cryptography
python2-cryptography-2.6.1-1.tar.xz: OK
Unpacking...
Package python2-cryptography requires the following packages, installing:
cygwin libopenssl100 python2 python2-asn1crypto python2-cffi python2-enum34 python2-idna python2-ipaddress python2-packaging python2-six python27-cryptography
Package cygwin is already installed, skipping
Package libopenssl100 is already installed, skipping
Package python2 is already installed, skipping
Installing python2-asn1crypto
python2-asn1crypto-0.24.0-1.tar.xz: OK
Unpacking...
Package python2-asn1crypto requires the following packages, installing:
python2 python27-asn1crypto
Package python2 is already installed, skipping
Package python27-asn1crypto is already installed, skipping
Installing python2-cffi
python2-cffi-1.12.2-1.tar.xz: OK
Unpacking...
Package python2-cffi requires the following packages, installing:
cygwin libffi6 libgcc1 python2 python2-pycparser python27-cffi
Package cygwin is already installed, skipping
Package libffi6 is already installed, skipping
Package libgcc1 is already installed, skipping
Package python2 is already installed, skipping
Installing python2-pycparser
python2-pycparser-2.19-1.tar.xz: OK
Unpacking...
Package python2-pycparser requires the following packages, installing:
python2 python2-ply python27-pycparser
Package python2 is already installed, skipping
Installing python2-ply
python2-ply-3.11-1.tar.xz: OK
Unpacking...
Package python2-ply requires the following packages, installing:
python2 python27-ply
Package python2 is already installed, skipping
Package python27-ply is already installed, skipping
Package python27-pycparser is already installed, skipping
Package python27-cffi is already installed, skipping
Installing python2-enum34
python2-enum34-1.1.6-2.tar.xz: OK
Unpacking...
Package python2-enum34 requires the following packages, installing:
python2 python27-enum34
Package python2 is already installed, skipping
Package python27-enum34 is already installed, skipping
Package python2-idna is already installed, skipping
Package python2-ipaddress is already installed, skipping
Package python2-packaging is already installed, skipping
Installing python2-six
python2-six-1.12.0-1.tar.xz: OK
Unpacking...
Package python2-six requires the following packages, installing:
python2 python27-six
Package python2 is already installed, skipping
Package python27-six is already installed, skipping
Package python27-cryptography is already installed, skipping
Installing python2-openssl
python2-openssl-19.0.0-1.tar.xz: OK
Unpacking...
Package python2-openssl requires the following packages, installing:
python2 python2-cryptography python2-six python27-openssl
Package python2 is already installed, skipping
Package python2-cryptography is already installed, skipping
Package python2-six is already installed, skipping
Package python27-openssl is already installed, skipping
Package python2-six is already installed, skipping
Package python27-urllib3 is already installed, skipping
Package python27-requests is already installed, skipping
Installing python2-setuptools
python2-setuptools-40.8.0-1.tar.xz: OK
Unpacking...
Package python2-setuptools requires the following packages, installing:
python2 python2-appdirs python2-packaging python2-six python27-setuptools
Package python2 is already installed, skipping
Package python2-appdirs is already installed, skipping
Package python2-packaging is already installed, skipping
Package python2-six is already installed, skipping
Package python27-setuptools is already installed, skipping
Package python2-six is already installed, skipping
Installing python2-wheel
python2-wheel-0.33.1-1.tar.xz: OK
Unpacking...
Package python2-wheel requires the following packages, installing:
python2 python2-setuptools python27-wheel
Package python2 is already installed, skipping
Package python2-setuptools is already installed, skipping
Package python27-wheel is already installed, skipping
Package python27-pip is already installed, skipping
Package python2-pip installed

Installing sqlite3
sqlite3-3.28.0-1.tar.xz: OK
Unpacking...
Package sqlite3 requires the following packages, installing:
cygwin libreadline7 libsqlite3_0 sqlite3-vfslog
Package cygwin is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package sqlite3-vfslog is already installed, skipping
Package sqlite3 installed

Looking up bootstrap.pypa.io
Making HTTPS connection to bootstrap.pypa.io
SSL callback:unable to get local issuer certificate, preverify_ok=0, ssl_okay=0
Retrying connection without TLS.
Looking up bootstrap.pypa.io
Making HTTPS connection to bootstrap.pypa.io
Alert!: Unable to make secure connection to remote host.

lynx: Can't access startfile https://bootstrap.pypa.io/get-pip.py
./background_installer.sh: line 148: pip: command not found
./background_installer.sh: line 149: pip: command not found
./background_installer.sh: line 150: pip: command not found

[MATIEC COMPILER]

[ST OPTIMIZER]
./background_installer.sh: line 164: g++: command not found
cp: cannot stat './st_optimizer.exe': No such file or directory
Error compiling ST Optimizer
OpenPLC was NOT installed!

Quote 0 0