danijel
hello,
I have gone trough all three steps from the troubleshooting and it is failing to install. Can someone help?


Danijel@DESKTOP-2SN0ESE ~
$ git clone https/: github.com/thiagoralves/OpenPLC_v3.git
fatal: destination path 'OpenPLC_v3' already exists and is not an empty directory.

Danijel@DESKTOP-2SN0ESE ~
$ rm -Rf OpenPLC_v3

Danijel@DESKTOP-2SN0ESE ~
$ git clone https://github.com/thiagoralves/OpenPLC_v3.git
Cloning into 'OpenPLC_v3'...
remote: Enumerating objects: 97, done.
remote: Counting objects: 100% (97/97), done.
remote: Compressing objects: 100% (70/70), done.
remote: Total 4860 (delta 37), reused 59 (delta 26), pack-reused 4763
Receiving objects: 100% (4860/4860), 11.24 MiB | 2.29 MiB/s, done.
Resolving deltas: 100% (2575/2575), done.
Checking out files: 100% (2769/2769), done.

Danijel@DESKTOP-2SN0ESE ~
$ cd OpenPLC_v3

Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$ ./ install.sh win
Installing OpenPLC on Windows
--15:27:02-- http://cygwin.mirror.constant.com//x86_64/setup.bz2
=> `setup.bz2'
Resolving cygwin.mirror.constant.com... done.
Connecting to cygwin.mirror.constant.com[108.61.5.83]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,961,550 [application/octet-stream]

0K .......... .......... .......... .......... .......... 1% 196.08 KB/s
50K .......... .......... .......... .......... .......... 2% 505.05 KB/s
100K .......... .......... .......... .......... .......... 3% 595.24 KB/s
150K .......... .......... .......... .......... .......... 5% 406.50 KB/s
200K .......... .......... .......... .......... .......... 6% 555.56 KB/s
250K .......... .......... .......... .......... .......... 7% 537.63 KB/s
300K .......... .......... .......... .......... .......... 9% 561.80 KB/s
350K .......... .......... .......... .......... .......... 10% 1.58 MB/s
400K .......... .......... .......... .......... .......... 11% 1.22 MB/s
450K .......... .......... .......... .......... .......... 12% 862.07 KB/s
500K .......... .......... .......... .......... .......... 14% 1.58 MB/s
550K .......... .......... .......... .......... .......... 15% 2.22 MB/s
600K .......... .......... .......... .......... .......... 16% 3.49 MB/s
650K .......... .......... .......... .......... .......... 18% 2.71 MB/s
700K .......... .......... .......... .......... .......... 19% 2.44 MB/s
750K .......... .......... .......... .......... .......... 20% 1.63 MB/s
800K .......... .......... .......... .......... .......... 21% 1.58 MB/s
850K .......... .......... .......... .......... .......... 23% 2.57 MB/s
900K .......... .......... .......... .......... .......... 24% 3.26 MB/s
950K .......... .......... .......... .......... .......... 25% 2.87 MB/s
1000K .......... .......... .......... .......... .......... 27% 3.49 MB/s
1050K .......... .......... .......... .......... .......... 28% 181.82 KB/s
1100K .......... .......... .......... .......... .......... 29% 2.57 MB/s
1150K .......... .......... .......... .......... .......... 31% 4.07 MB/s
1200K .......... .......... .......... .......... .......... 32% 3.49 MB/s
1250K .......... .......... .......... .......... .......... 33% 170.65 KB/s
1300K .......... .......... .......... .......... .......... 34% 48.83 MB/s
1350K .......... .......... .......... .......... .......... 36% 48.83 MB/s
1400K .......... .......... .......... .......... .......... 37% 304.88 KB/s
1450K .......... .......... .......... .......... .......... 38% 8.14 MB/s
1500K .......... .......... .......... .......... .......... 40% 48.83 MB/s
1550K .......... .......... .......... .......... .......... 41% 384.62 KB/s
1600K .......... .......... .......... .......... .......... 42% 3.49 MB/s
1650K .......... .......... .......... .......... .......... 43% 1.95 MB/s
1700K .......... .......... .......... .......... .......... 45% 12.21 MB/s
1750K .......... .......... .......... .......... .......... 46% 48.83 MB/s
1800K .......... .......... .......... .......... .......... 47% 48.83 MB/s
1850K .......... .......... .......... .......... .......... 49% 267.38 KB/s
1900K .......... .......... .......... .......... .......... 50% 48.83 MB/s
1950K .......... .......... .......... .......... .......... 51% 48.83 MB/s
2000K .......... .......... .......... .......... .......... 52% 48.83 MB/s
2050K .......... .......... .......... .......... .......... 54% 48.83 MB/s
2100K .......... .......... .......... .......... .......... 55% 48.83 MB/s
2150K .......... .......... .......... .......... .......... 56% 48.83 MB/s
2200K .......... .......... .......... .......... .......... 58% 48.83 MB/s
2250K .......... .......... .......... .......... .......... 59% 1.16 MB/s
2300K .......... .......... .......... .......... .......... 60% 48.83 MB/s
2350K .......... .......... .......... .......... .......... 62% 48.83 MB/s
2400K .......... .......... .......... .......... .......... 63% 48.83 MB/s
2450K .......... .......... .......... .......... .......... 64% 48.83 MB/s
2500K .......... .......... .......... .......... .......... 65% 48.83 MB/s
2550K .......... .......... .......... .......... .......... 67% 48.83 MB/s
2600K .......... .......... .......... .......... .......... 68% 48.83 MB/s
2650K .......... .......... .......... .......... .......... 69% 48.83 MB/s
2700K .......... .......... .......... .......... .......... 71% 16.28 MB/s
2750K .......... .......... .......... .......... .......... 72% 2.33 MB/s
2800K .......... .......... .......... .......... .......... 73% 2.03 MB/s
2850K .......... .......... .......... .......... .......... 74% 2.87 MB/s
2900K .......... .......... .......... .......... .......... 76% 2.71 MB/s
2950K .......... .......... .......... .......... .......... 77% 2.57 MB/s
3000K .......... .......... .......... .......... .......... 78% 2.71 MB/s
3050K .......... .......... .......... .......... .......... 80% 2.57 MB/s
3100K .......... .......... .......... .......... .......... 81% 2.71 MB/s
3150K .......... .......... .......... .......... .......... 82% 2.22 MB/s
3200K .......... .......... .......... .......... .......... 84% 2.71 MB/s
3250K .......... .......... .......... .......... .......... 85% 2.71 MB/s
3300K .......... .......... .......... .......... .......... 86% 2.71 MB/s
3350K .......... .......... .......... .......... .......... 87% 2.87 MB/s
3400K .......... .......... .......... .......... .......... 89% 2.57 MB/s
3450K .......... .......... .......... .......... .......... 90% 2.44 MB/s
3500K .......... .......... .......... .......... .......... 91% 3.05 MB/s
3550K .......... .......... .......... .......... .......... 93% 1.95 MB/s
3600K .......... .......... .......... .......... .......... 94% 2.87 MB/s
3650K .......... .......... .......... .......... .......... 95% 2.71 MB/s
3700K .......... .......... .......... .......... .......... 96% 2.71 MB/s
3750K .......... .......... .......... .......... .......... 98% 2.87 MB/s
3800K .......... .......... .......... .......... .......... 99% 2.57 MB/s
3850K .......... ........ 100% 14.20 KB/s

15:27:06 (938.78 KB/s) - `setup.bz2' saved [3961550/3961550]

Updated setup.ini
Package lynx is already installed, skipping
Removing gcc-core
Package gcc-core removed
Removing gcc-g++
Package gcc-g++ removed
Removing pkg-config
Package pkg-config removed
Removing automake
Package automake removed
Removing autoconf
Package autoconf removed
Removing libtool
Package libtool removed
Removing make
Package make removed
Removing python2
Package python2 removed
Package manifest missing, cannot remove python2-pip. Exiting
Package wget is already installed, skipping
Installing gcc-core
gcc-core-7.4.0-1.tar.xz: OK
Unpacking...
Package gcc-core requires the following packages, installing:
bash binutils cygwin cygwin-devel libatomic1 libgcc1 libgmp10 libgomp1 libiconv2 libl8 libisl15 libmpc3 libmpfr6 libquadmath0 w32api-headers w32api-runtime windows-defa-manifest zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package cygwin-devel is already installed, skipping
Package libatomic1 is already installed, skipping
Package libgcc1 is already installed, skipping
Package libgmp10 is already installed, skipping
Package libgomp1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libquadmath0 is already installed, skipping
Package w32api-headers is already installed, skipping
Package w32api-runtime is already installed, skipping
Package windows-default-manifest is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-core installed

Installing gcc-g++
gcc-g++-7.4.0-1.tar.xz: OK
Unpacking...
Package gcc-g++ requires the following packages, installing:
cygwin gcc-core libgmp10 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libstdc++6 zli
Package cygwin is already installed, skipping
Package gcc-core is already installed, skipping
Package libgmp10 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libstdc++6 is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-g++ installed
Package git is already installed, skipping

Installing pkg-config
pkg-config-1.6.0-1.tar.xz: OK
Unpacking...
Package pkg-config requires the following packages, installing:
bash cygwin libglib2.0_0 pkgconf
Package bash is already installed, skipping
Package cygwin is already installed, skipping
Package libglib2.0_0 is already installed, skipping
Package pkgconf is already installed, skipping
Package pkg-config installed

Installing automake
automake-11-1.tar.xz: OK
Unpacking...
Package automake requires the following packages, installing:
automake1.10 automake1.11 automake1.12 automake1.13 automake1.14 automake1.15 automa.16 automake1.4 automake1.5 automake1.6 automake1.7 automake1.8 automake1.9 bash gaw
Package automake1.10 is already installed, skipping
Package automake1.11 is already installed, skipping
Package automake1.12 is already installed, skipping
Package automake1.13 is already installed, skipping
Package automake1.14 is already installed, skipping
Package automake1.15 is already installed, skipping
Package automake1.16 is already installed, skipping
Package automake1.4 is already installed, skipping
Package automake1.5 is already installed, skipping
Package automake1.6 is already installed, skipping
Package automake1.7 is already installed, skipping
Package automake1.8 is already installed, skipping
Package automake1.9 is already installed, skipping
Package bash is already installed, skipping
Package gawk is already installed, skipping
Package automake installed

Installing autoconf
autoconf-13-1.tar.bz2: OK
Unpacking...
Package autoconf requires the following packages, installing:
autoconf2.1 autoconf2.5 bash sed
Package autoconf2.1 is already installed, skipping
Package autoconf2.5 is already installed, skipping
Package bash is already installed, skipping
Package sed is already installed, skipping
Running /etc/postinstall/ autoconf.sh
Package autoconf installed

Installing libtool
libtool-2.4.6-7.tar.xz: OK
Unpacking...
Package libtool requires the following packages, installing:
bash libltdl7
Package bash is already installed, skipping
Package libltdl7 is already installed, skipping
Package libtool installed

Installing make
make-4.2.1-2.tar.xz: OK
Unpacking...
Package make requires the following packages, installing:
cygwin libguile17 libguile2.0_22 libintl8
Package cygwin is already installed, skipping
Package libguile17 is already installed, skipping
Package libguile2.0_22 is already installed, skipping
Package libintl8 is already installed, skipping
Package make installed

Installing python2
python2-2.7.16-1.tar.xz: OK
Unpacking...
Package python2 requires the following packages, installing:
bash binutils cygwin libbz2_1 libcrypt0 libdb5.3 libexpat1 libffi6 libgdbm4 libgdbm_pat4 libintl8 libncursesw10 libopenssl100 libreadline7 libsqlite3_0 libuuid-devel pyn27 zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package libbz2_1 is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libffi6 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libgdbm_compat4 is already installed, skipping
Package libintl8 is already installed, skipping
Package libncursesw10 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package libuuid-devel is already installed, skipping
Package python27 is already installed, skipping
Package zlib0 is already installed, skipping
Package python2 installed
Package python2-pip is already installed, skipping
Package sqlite3 is already installed, skipping
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please rade your Python as Python 2.7 won't be maintained after that date. A future version pip will drop support for Python 2.7. More details about Python 2 support in pip, cbe found at https://pip.pypa.io/en/latest/development/release-process/#python-2-supp
Collecting pip
Using cached https://files.pythonhosted.org/packages/00/b6/9cfa56b4081ad13874b0c6ff8ce16cfbc1cb06bedf8e9164ce5551ec1/pip-19.3.1-py2.py3-none-any.whl
Installing collected packages: pip
Found existing installation: pip 19.3.1
Uninstalling pip-19.3.1:
Successfully uninstalled pip-19.3.1
Successfully installed pip-19.3.1
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please rade your Python as Python 2.7 won't be maintained after that date. A future version pip will drop support for Python 2.7. More details about Python 2 support in pip, cbe found at https://pip.pypa.io/en/latest/development/release-process/#python-2-supp
Requirement already satisfied: flask in /usr/lib/python2.7/site-packages (1.1.1)
Requirement already satisfied: Jinja2>=2.10.1 in /usr/lib/python2.7/site-packages (f flask) (2.10.3)
Requirement already satisfied: itsdangerous>=0.24 in /usr/lib/python2.7/site-packagefrom flask) (1.1.0)
Requirement already satisfied: Werkzeug>=0.15 in /usr/lib/python2.7/site-packages (f flask) (0.16.0)
Requirement already satisfied: click>=5.1 in /usr/lib/python2.7/site-packages (from sk) (7.0)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib/python2.7/site-packages om Jinja2>=2.10.1->flask) (1.1.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please rade your Python as Python 2.7 won't be maintained after that date. A future version pip will drop support for Python 2.7. More details about Python 2 support in pip, cbe found at https://pip.pypa.io/en/latest/development/release-process/#python-2-supp
Requirement already satisfied: flask-login in /usr/lib/python2.7/site-packages (0.4.
Requirement already satisfied: Flask in /usr/lib/python2.7/site-packages (from flaskgin) (1.1.1)
Requirement already satisfied: Jinja2>=2.10.1 in /usr/lib/python2.7/site-packages (f Flask->flask-login) (2.10.3)
Requirement already satisfied: itsdangerous>=0.24 in /usr/lib/python2.7/site-packagefrom Flask->flask-login) (1.1.0)
Requirement already satisfied: Werkzeug>=0.15 in /usr/lib/python2.7/site-packages (f Flask->flask-login) (0.16.0)
Requirement already satisfied: click>=5.1 in /usr/lib/python2.7/site-packages (from sk->flask-login) (7.0)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib/python2.7/site-packages om Jinja2>=2.10.1->Flask->flask-login) (1.1.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please rade your Python as Python 2.7 won't be maintained after that date. A future version pip will drop support for Python 2.7. More details about Python 2 support in pip, cbe found at https://pip.pypa.io/en/latest/development/release-process/#python-2-supp
Requirement already satisfied: pyserial in /usr/lib/python2.7/site-packages (3.4)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please rade your Python as Python 2.7 won't be maintained after that date. A future version pip will drop support for Python 2.7. More details about Python 2 support in pip, cbe found at https://pip.pypa.io/en/latest/development/release-process/#python-2-supp
Requirement already satisfied: pymodbus in /usr/lib/python2.7/site-packages (2.3.0)
Requirement already satisfied: six>=1.11.0 in /usr/lib/python2.7/site-packages (frommodbus) (1.13.0)
Requirement already satisfied: pyserial>=3.4 in /usr/lib/python2.7/site-packages (frpymodbus) (3.4)

[MATIEC COMPILER]

[ST OPTIMIZER]

[GLUE GENERATOR]

[OPEN DNP3]

[LIBMODBUS]
/usr/bin/autoreconf: /usr/bin/autoreconf-2.69: /usr/bin/perl: bad interpreter: No sufile or directory
/usr/bin/autoreconf: line 201: /usr/bin/autoreconf-2.69: No error

--------------------------
Running autoreconf failed.
--------------------------

./background_installer.sh: line 214: ./configure: No such file or directory
make: *** No rule to make target 'install'. Stop.
Error installing Libmodbus
OpenPLC was NOT installed!

Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$
Quote 0 0
thiagoralves
Looks like something is wrong with your Perl interpreter. It should have come integrated with Cygwin install. In any case, this should fix it:
apt-cyg remove perl
apt-cyg install perl

Then try installing OpenPLC again.
Quote 0 0
danijel
Same again, can I try something else?



Danijel@DESKTOP-2SN0ESE ~
$ apt-cyg remove perl
Removing perl
apPackage perl removed

Danijel@DESKTOP-2SN0ESE ~
$ apt-cyg install perl
Installing perl
perl-5.26.3-2.tar.xz: OK
Unpacking...
Package perl requires the following packages, installing:
cygwin libcrypt0 libcrypt2 libdb5.3 libgdbm4 libgdbm6 libgdbm_compat4 perl_autorebase perl_base
Package cygwin is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libcrypt2 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libgdbm6 is already installed, skipping
Package libgdbm_compat4 is already installed, skipping
Package perl_autorebase is already installed, skipping
Package perl_base is already installed, skipping
Package perl installed

Danijel@DESKTOP-2SN0ESE ~
$ git clone https://github.com/thiagoralves/OpenPLC_v3.git
fatal: destination path 'OpenPLC_v3' already exists and is not an empty directory.

Danijel@DESKTOP-2SN0ESE ~
$ rm -Rf OpenPLC_v3

Danijel@DESKTOP-2SN0ESE ~
$ git clone https://github.com/thiagoralves/OpenPLC_v3.git
Cloning into 'OpenPLC_v3'...
remote: Enumerating objects: 97, done.
remote: Counting objects: 100% (97/97), done.
remote: Compressing objects: 100% (70/70), done.
remote: Total 4860 (delta 37), reused 59 (delta 26), pack-reused 4763
Receiving objects: 100% (4860/4860), 11.24 MiB | 1.86 MiB/s, done.
Resolving deltas: 100% (2575/2575), done.
Checking out files: 100% (2769/2769), done.

Danijel@DESKTOP-2SN0ESE ~
$ cd OpenPLC_v3

Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$ ./ install.sh win
Installing OpenPLC on Windows
--19:02:06-- http://cygwin.mirror.constant.com//x86_64/setup.bz2
=> `setup.bz2'
Resolving cygwin.mirror.constant.com... done.
Connecting to cygwin.mirror.constant.com[108.61.5.83]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,961,550 [application/octet-stream]

0K .......... .......... .......... .......... .......... 1% 183.82 KB/s
50K .......... .......... .......... .......... .......... 2% 510.20 KB/s
100K .......... .......... .......... .......... .......... 3% 537.63 KB/s
150K .......... .......... .......... .......... .......... 5% 423.73 KB/s
200K .......... .......... .......... .......... .......... 6% 531.91 KB/s
250K .......... .......... .......... .......... .......... 7% 1.48 MB/s
300K .......... .......... .......... .......... .......... 9% 526.32 KB/s
350K .......... .......... .......... .......... .......... 10% 1.40 MB/s
400K .......... .......... .......... .......... .......... 11% 2.12 MB/s
450K .......... .......... .......... .......... .......... 12% 2.33 MB/s
500K .......... .......... .......... .......... .......... 14% 1.40 MB/s
550K .......... .......... .......... .......... .......... 15% 943.40 KB/s
600K .......... .......... .......... .......... .......... 16% 2.44 MB/s
650K .......... .......... .......... .......... .......... 18% 3.05 MB/s
700K .......... .......... .......... .......... .......... 19% 3.26 MB/s
750K .......... .......... .......... .......... .......... 20% 3.26 MB/s
800K .......... .......... .......... .......... .......... 21% 3.05 MB/s
850K .......... .......... .......... .......... .......... 23% 322.58 KB/s
900K .......... .......... .......... .......... .......... 24% 314.47 KB/s
950K .......... .......... .......... .......... .......... 25% 48.83 MB/s
1000K .......... .......... .......... .......... .......... 27% 2.12 MB/s
1050K .......... .......... .......... .......... .......... 28% 48.83 MB/s
1100K .......... .......... .......... .......... .......... 29% 48.83 MB/s
1150K .......... .......... .......... .......... .......... 31% 48.83 MB/s
1200K .......... .......... .......... .......... .......... 32% 48.83 MB/s
1250K .......... .......... .......... .......... .......... 33% 48.83 MB/s
1300K .......... .......... .......... .......... .......... 34% 48.83 MB/s
1350K .......... .......... .......... .......... .......... 36% 48.83 MB/s
1400K .......... .......... .......... .......... .......... 37% 48.83 MB/s
1450K .......... .......... .......... .......... .......... 38% 154.80 KB/s
1500K .......... .......... .......... .......... .......... 40% 9.77 MB/s
1550K .......... .......... .......... .......... .......... 41% 48.83 MB/s
1600K .......... .......... .......... .......... .......... 42% 8.14 MB/s
1650K .......... .......... .......... .......... .......... 43% 48.83 MB/s
1700K .......... .......... .......... .......... .......... 45% 24.41 MB/s
1750K .......... .......... .......... .......... .......... 46% 5.43 MB/s
1800K .......... .......... .......... .......... .......... 47% 267.38 KB/s
1850K .......... .......... .......... .......... .......... 49% 4.44 MB/s
1900K .......... .......... .......... .......... .......... 50% 5.43 MB/s
1950K .......... .......... .......... .......... .......... 51% 1.95 MB/s
2000K .......... .......... .......... .......... .......... 52% 5.43 MB/s
2050K .......... .......... .......... .......... .......... 54% 2.44 MB/s
2100K .......... .......... .......... .......... .......... 55% 48.83 MB/s
2150K .......... .......... .......... .......... .......... 56% 48.83 MB/s
2200K .......... .......... .......... .......... .......... 58% 48.83 MB/s
2250K .......... .......... .......... .......... .......... 59% 48.83 MB/s
2300K .......... .......... .......... .......... .......... 60% 48.83 MB/s
2350K .......... .......... .......... .......... .......... 62% 16.28 MB/s
2400K .......... .......... .......... .......... .......... 63% 961.54 KB/s
2450K .......... .......... .......... .......... .......... 64% 2.71 MB/s
2500K .......... .......... .......... .......... .......... 65% 2.71 MB/s
2550K .......... .......... .......... .......... .......... 67% 3.05 MB/s
2600K .......... .......... .......... .......... .......... 68% 3.05 MB/s
2650K .......... .......... .......... .......... .......... 69% 3.05 MB/s
2700K .......... .......... .......... .......... .......... 71% 3.26 MB/s
2750K .......... .......... .......... .......... .......... 72% 3.05 MB/s
2800K .......... .......... .......... .......... .......... 73% 3.05 MB/s
2850K .......... .......... .......... .......... .......... 74% 3.26 MB/s
2900K .......... .......... .......... .......... .......... 76% 2.33 MB/s
2950K .......... .......... .......... .......... .......... 77% 3.26 MB/s
3000K .......... .......... .......... .......... .......... 78% 1.88 MB/s
3050K .......... .......... .......... .......... .......... 80% 143.27 KB/s
3100K .......... .......... .......... .......... .......... 81% 3.49 MB/s
3150K .......... .......... .......... .......... .......... 82% 1.63 MB/s
3200K .......... .......... .......... .......... .......... 84% 3.26 MB/s
3250K .......... .......... .......... .......... .......... 85% 48.83 MB/s
3300K .......... .......... .......... .......... .......... 86% 48.83 MB/s
3350K .......... .......... .......... .......... .......... 87% 48.83 MB/s
3400K .......... .......... .......... .......... .......... 89% 48.83 MB/s
3450K .......... .......... .......... .......... .......... 90% 48.83 MB/s
3500K .......... .......... .......... .......... .......... 91% 8.14 MB/s
3550K .......... .......... .......... .......... .......... 93% 48.83 MB/s
3600K .......... .......... .......... .......... .......... 94% 48.83 MB/s
3650K .......... .......... .......... .......... .......... 95% 48.83 MB/s
3700K .......... .......... .......... .......... .......... 96% 2.57 MB/s
3750K .......... .......... .......... .......... .......... 98% 1.68 MB/s
3800K .......... .......... .......... .......... .......... 99% 16.28 MB/s
3850K .......... ........ 100% 13.26 KB/s

19:02:11 (934.24 KB/s) - `setup.bz2' saved [3961550/3961550]

Updated setup.ini
Package lynx is already installed, skipping
Removing gcc-core
Package gcc-core removed
Removing gcc-g++
Package gcc-g++ removed
Removing pkg-config
Package pkg-config removed
Removing automake
Package automake removed
Removing autoconf
Package autoconf removed
Removing libtool
Package libtool removed
Removing make
Package make removed
Removing python2
Package python2 removed
Package manifest missing, cannot remove python2-pip. Exiting
Package wget is already installed, skipping
Installing gcc-core
gcc-core-7.4.0-1.tar.xz: OK
Unpacking...
Package gcc-core requires the following packages, installing:
bash binutils cygwin cygwin-devel libatomic1 libgcc1 libgmp10 libgomp1 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libquadmath0 w32api-headers w32api-runtime windows-default-manifest zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package cygwin-devel is already installed, skipping
Package libatomic1 is already installed, skipping
Package libgcc1 is already installed, skipping
Package libgmp10 is already installed, skipping
Package libgomp1 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libquadmath0 is already installed, skipping
Package w32api-headers is already installed, skipping
Package w32api-runtime is already installed, skipping
Package windows-default-manifest is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-core installed

Installing gcc-g++
gcc-g++-7.4.0-1.tar.xz: OK
Unpacking...
Package gcc-g++ requires the following packages, installing:
cygwin gcc-core libgmp10 libiconv2 libintl8 libisl15 libmpc3 libmpfr6 libstdc++6 zlib0
Package cygwin is already installed, skipping
Package gcc-core is already installed, skipping
Package libgmp10 is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libisl15 is already installed, skipping
Package libmpc3 is already installed, skipping
Package libmpfr6 is already installed, skipping
Package libstdc++6 is already installed, skipping
Package zlib0 is already installed, skipping
Package gcc-g++ installed
Package git is already installed, skipping

Installing pkg-config
pkg-config-1.6.0-1.tar.xz: OK
Unpacking...
Package pkg-config requires the following packages, installing:
bash cygwin libglib2.0_0 pkgconf
Package bash is already installed, skipping
Package cygwin is already installed, skipping
Package libglib2.0_0 is already installed, skipping
Package pkgconf is already installed, skipping
Package pkg-config installed

Installing automake
automake-11-1.tar.xz: OK
Unpacking...
Package automake requires the following packages, installing:
automake1.10 automake1.11 automake1.12 automake1.13 automake1.14 automake1.15 automake1.16 automake1.4 automake1.5 automake1.6 automake1.7 automake1.8 automake1.9 bash gawk
Package automake1.10 is already installed, skipping
Package automake1.11 is already installed, skipping
Package automake1.12 is already installed, skipping
Package automake1.13 is already installed, skipping
Package automake1.14 is already installed, skipping
Package automake1.15 is already installed, skipping
Package automake1.16 is already installed, skipping
Package automake1.4 is already installed, skipping
Package automake1.5 is already installed, skipping
Package automake1.6 is already installed, skipping
Package automake1.7 is already installed, skipping
Package automake1.8 is already installed, skipping
Package automake1.9 is already installed, skipping
Package bash is already installed, skipping
Package gawk is already installed, skipping
Package automake installed

Installing autoconf
autoconf-13-1.tar.bz2: OK
Unpacking...
Package autoconf requires the following packages, installing:
autoconf2.1 autoconf2.5 bash sed
Package autoconf2.1 is already installed, skipping
Package autoconf2.5 is already installed, skipping
Package bash is already installed, skipping
Package sed is already installed, skipping
Running /etc/postinstall/ autoconf.sh
Package autoconf installed

Installing libtool
libtool-2.4.6-7.tar.xz: OK
Unpacking...
Package libtool requires the following packages, installing:
bash libltdl7
Package bash is already installed, skipping
Package libltdl7 is already installed, skipping
Package libtool installed

Installing make
make-4.2.1-2.tar.xz: OK
Unpacking...
Package make requires the following packages, installing:
cygwin libguile17 libguile2.0_22 libintl8
Package cygwin is already installed, skipping
Package libguile17 is already installed, skipping
Package libguile2.0_22 is already installed, skipping
Package libintl8 is already installed, skipping
Package make installed

Installing python2
python2-2.7.16-1.tar.xz: OK
Unpacking...
Package python2 requires the following packages, installing:
bash binutils cygwin libbz2_1 libcrypt0 libdb5.3 libexpat1 libffi6 libgdbm4 libgdbm_compat4 libintl8 libncursesw10 libopenssl100 libreadline7 libsqlite3_0 libuuid-devel python27 zlib0
Package bash is already installed, skipping
Package binutils is already installed, skipping
Package cygwin is already installed, skipping
Package libbz2_1 is already installed, skipping
Package libcrypt0 is already installed, skipping
Package libdb5.3 is already installed, skipping
Package libexpat1 is already installed, skipping
Package libffi6 is already installed, skipping
Package libgdbm4 is already installed, skipping
Package libgdbm_compat4 is already installed, skipping
Package libintl8 is already installed, skipping
Package libncursesw10 is already installed, skipping
Package libopenssl100 is already installed, skipping
Package libreadline7 is already installed, skipping
Package libsqlite3_0 is already installed, skipping
Package libuuid-devel is already installed, skipping
Package python27 is already installed, skipping
Package zlib0 is already installed, skipping
Package python2 installed
Package python2-pip is already installed, skipping
Package sqlite3 is already installed, skipping
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting pip
Using cached https://files.pythonhosted.org/packages/00/b6/9cfa56b4081ad13874b0c6f96af8ce16cfbc1cb06bedf8e9164ce5551ec1/pip-19.3.1-py2.py3-none-any.whl
Installing collected packages: pip
Found existing installation: pip 19.3.1
Uninstalling pip-19.3.1:
Successfully uninstalled pip-19.3.1
Successfully installed pip-19.3.1
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: flask in /usr/lib/python2.7/site-packages (1.1.1)
Requirement already satisfied: Jinja2>=2.10.1 in /usr/lib/python2.7/site-packages (from flask) (2.10.3)
Requirement already satisfied: itsdangerous>=0.24 in /usr/lib/python2.7/site-packages (from flask) (1.1.0)
Requirement already satisfied: Werkzeug>=0.15 in /usr/lib/python2.7/site-packages (from flask) (0.16.0)
Requirement already satisfied: click>=5.1 in /usr/lib/python2.7/site-packages (from flask) (7.0)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib/python2.7/site-packages (from Jinja2>=2.10.1->flask) (1.1.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: flask-login in /usr/lib/python2.7/site-packages (0.4.1)
Requirement already satisfied: Flask in /usr/lib/python2.7/site-packages (from flask-login) (1.1.1)
Requirement already satisfied: Jinja2>=2.10.1 in /usr/lib/python2.7/site-packages (from Flask->flask-login) (2.10.3)
Requirement already satisfied: itsdangerous>=0.24 in /usr/lib/python2.7/site-packages (from Flask->flask-login) (1.1.0)
Requirement already satisfied: Werkzeug>=0.15 in /usr/lib/python2.7/site-packages (from Flask->flask-login) (0.16.0)
Requirement already satisfied: click>=5.1 in /usr/lib/python2.7/site-packages (from Flask->flask-login) (7.0)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib/python2.7/site-packages (from Jinja2>=2.10.1->Flask->flask-login) (1.1.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: pyserial in /usr/lib/python2.7/site-packages (3.4)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: pymodbus in /usr/lib/python2.7/site-packages (2.3.0)
Requirement already satisfied: six>=1.11.0 in /usr/lib/python2.7/site-packages (from pymodbus) (1.13.0)
Requirement already satisfied: pyserial>=3.4 in /usr/lib/python2.7/site-packages (from pymodbus) (3.4)

[MATIEC COMPILER]

[ST OPTIMIZER]

[GLUE GENERATOR]

[OPEN DNP3]

[LIBMODBUS]
/usr/bin/autoreconf: /usr/bin/autoreconf-2.69: /usr/bin/perl: bad interpreter: No such file or directory
/usr/bin/autoreconf: line 201: /usr/bin/autoreconf-2.69: No error

--------------------------
Running autoreconf failed.
--------------------------

./background_installer.sh: line 214: ./configure: No such file or directory
make: *** No rule to make target 'install'. Stop.
Error installing Libmodbus
OpenPLC was NOT installed!

Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$
Quote 0 0
thiagoralves
This is very weird. Something has definitely corrupted Perl in you Cygwin setup. If you open cygwin terminal and just type perl, can you enter on the interpreter or does it gives you an error message? You can type Ctrl+C to exit the interpreter. One thing you can try is just to remove everything and install cygwin again on the default location (C:\cygwin64) making sure that the git package is selected. Then you can go from there. 
Quote 0 0
danijel
here it is


Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$ perl
-bash: perl: command not found

Danijel@DESKTOP-2SN0ESE ~/OpenPLC_v3
$

ok, I will try that
Quote 0 0
thiagoralves
Check https://www.perlmonks.org/?node_id=322531

This post made me think. Do you have Perl for Windows installed in your system by any chance? To check, just open command prompt (not cygwin terminal) clicking on Start -> cmd and type perl. If you get an error, then Perl for Windows is not installed. But if you get into the interpreter, then you have Perl for Windows installed. This can be an issue, because when Cygwin tries to use the Linux/Unix perl, the Windows version gets called instead, and then the perl scripts are incorrectly parsed.
Quote 0 0
danijel
This I get in cmd:

C:\Users\Danijel>perl
'perl' is not recognized as an internal or external command,
operable program or batch file.
Quote 0 0