alexander1992
Hello,

I have the following problem. I use the Raspberry Pi 4 for this server. When I start the PLC Server, I get the following error: "Warning: Persistent Storage file not found"

How do I fix the warning?

Best regards,
Alexander
Quote 0 0
thiagoralves
This is not a problem. It just means that persistent storage is disabled. If you don’t know what persistent storage does, it’s better you leave it disabled
Quote 0 0
alexander1992
okay, thank you.

I'm still not getting anywhere. I have converted with my Raspberry Pi 4 everything from the video. But when I press the button, the LED doesn't light up.
Video: 


Best regards,
Alexander
Quote 0 0
thiagoralves
1. Check your wiring. Make sure the LED and Button are connected to the right pins
2. Check your program and make sure the location of your variables are on the correct pins
3. Check you driver. Make sure you enabled the Raspberry Pi driver on the Hardware page
Quote 0 0
alexander1992
Thank you for the answer.

i wrote an python-script for the button and led-check and if i press the button, then the led goes on.
OpenPLC is enabled for of Raspberry Pi driver and all pins are right set.

Have you an other idea?
Quote 0 0
thiagoralves
What I would do is start over from scratch with a blank image of raspbian (to make sure no other process is interfering with OpenPLC) and then follow the guide on
https://www.openplcproject.com/getting-started-rpi
to install it and then the guide on
https://www.openplcproject.com/reference-your-first-project
to create your first project.
Quote 0 0